0
$\begingroup$

Rosanswers logo

In Hokuyo Laser the scan values are getting dealyed from gazebo

  <gazebo reference="hokuyo_link">
<sensor type="ray" name="head_hokuyo_sensor">
  <pose>0.0 0 0.0 0 -0 0</pose>
  <ray>
    <scan>
      <horizontal>
        <samples>720</samples>
        <resolution>1</resolution>
        <min_angle>-1.58079</min_angle>
        <max_angle>1.58079</max_angle>
      </horizontal>
    </scan>
    <range>
      <min>0.08</min>
      <max>5</max>
      <resolution>0.01</resolution>
    </range>
    <noise>
      <type>gaussian</type>
      <mean>0.0</mean>
      <stddev>0.01</stddev>
    </noise>
  </ray>
  <plugin name="gazebo_ros_head_hokuyo_controller" filename="libgazebo_ros_laser.so">
    <always_on>1</always_on>
    <topicName>/sk/laser/scan</topicName>
    <frameName>hokuyo_link</frameName>
    <visualize>true</visualize>
  </plugin>
  <always_on>1</always_on>
  <update_rate>30</update_rate>
  <visualize>true</visualize>
</sensor>

gazebo veiw


Originally posted by me_saw on ROS Answers with karma: 31 on 2020-04-04

Post score: 0


Original comments

Comment by Teo Cardoso on 2020-04-05:
Could you formulate better your question? Show us more data about the problem. It helps us to help you.

Comment by me_saw on 2020-04-06:
Laser values are not getting accurately, laser is kind of blinking so some values are missing from left and and right

Comment by Teo Cardoso on 2020-04-06:
I tried here your laser settings on my robot. And the laser is working fine.

https://pasteboard.co/J2zz95B.png

I just copy and paste what you post here. So the problem isn't in the code.

Comment by me_saw on 2020-04-06:
Then what could be the problem? It's like the laser is flickering from left and right to some angle because of this laser values are missing

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I was checking here and increase the range tag

Try to increase <min>0.08</min>

The values are just an example, but it is a good start.


Originally posted by Teo Cardoso with karma: 378 on 2020-04-06

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by me_saw on 2020-04-06:
Isn't the clip tag used in camera plugin?

Comment by Teo Cardoso on 2020-04-06:
Sorry, I'm out of my mind. Try to increase 0.08

Comment by me_saw on 2020-04-06:
No problem Thanks I'll try it out

Comment by me_saw on 2020-04-06:
Thank you:) it solved the problem I increased the min to 0.28 and it's working perfectly. I guess the problem was the dimensions of my model

can you answer it separate so that I can mark it as correct.

Comment by Teo Cardoso on 2020-04-06:
I edited the comment. I'm glad to help ^^

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.