I installed Multiple versions of APM (2.0.7, 2.0.17, 2.0.18) on Windows 7, Ubuntu 14.04, and OSX 10.11. I could connect to my ArduPilot but could not install firmware. Here's the error I would get:

Started downloading http://firmware.diydrones.com/Copter/stable/apm2-hexa/ArduCopter.hex
Finished downloading /var/folders/r4/s_j4c02s3wvcx6wy41__rnwh0000gp/T/APM Planner.uq1800
Opening firmware file...
Unable to open file: /var/folders/r4/s_j4c02s3wvcx6wy41__rnwh0000gp/T/APM Planner.uq1800

1 Answer 1


For hours I've been dealing with this and no one has documented the same issue online. I tried the following with no success:

  • Changed permissions of parent folder /var/folders/r4/s_j4c02s3wvcx6wy41__rnwh0000gp/T
  • Ran APM as sudo
  • Multiple versions of APM
  • Multiple operating systems

I had to get a bit creative to come up with a workable solution:


When APM tried to download the firmware, you could see the temp file until you clicked "OK" in regard to the firmware failure. What I did was copied that file and found the following html in there:

<title>302 Found</title>
<p>The document has moved <a href="http://firmware.ardupilot.org/Copter/stable/apm2-hexa/ArduCopter.hex">here</a>.</p>
<address>Apache/2.4.7 (Ubuntu) Server at firmware.diydrones.com Port 80</address>

Obviously this is a server issue so here's what I did to get around it:

  • Downloaded the file mentioned in the html (http://firmware.ardupilot.org/Copter/stable/apm2-hexa/ArduCopter.hex) to my desktop
  • Changed the file format from txt to hex
  • Set APM Planner to advanced mode via File > Advanced Mode
  • In Initial Setup > Install Firmware Menu I selected Firmware Options > Custom
  • Chose the hex file I had downloaded



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.