0
$\begingroup$

Rosanswers logo

Following the tutorial http://wiki.ros.org/melodic/Installation/Ubuntu to install ROS Melodic I'm using Ubuntu 18.04 on x86_64. I had Ubuntu 16.04 with ROS Kinetic previously. I removed ROS Kinetic from Ubuntu 16.04. Upgraded from Ubuntu 16.04 to Ubuntu 18.04 and then trying to install ROS melodic.

Error:

sudo: unable to execute /usr/local/bin/rosdep: No such file or directory

Originally posted by srujan on ROS Answers with karma: 32 on 2020-02-10

Post score: 0

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

The version of rosdep that comes from the debian packages should be in /usr/bin not /usr/local/bin

I'd hazard a guess that you had a from source or from pip installation on your system at some point previously. During your upgrade you removed it, but there's still a reference to it on your path.

You might have an alias or other thing in your users' or root's .bashrc or other environment setup that needs to be cleaned up. Or you might have a redirection script somewhere that's out of date.


Originally posted by tfoote with karma: 58457 on 2020-02-10

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by srujan on 2020-02-10:
I have definitely used pip installation previously. I also had anaconda3 which was redirecting the python to a different location, hence I removed anaconda3 completely. Now, I removed the melodic and its dependencies and reinstalled melodic again. Still I get the same error. Can you show me a direction where those redirection scripts could be?

Thank you

Comment by tfoote on 2020-02-10:
Unfortunately I don't know what you've done on your system to cause it to look in that location. My best guesses are above to look for aliases in your bash settings. Reinstalling melodic isn't going to make a difference if your environment is pointing to the wrong place. It sounds like you've used a bunch of tools that change your environment like anaconda so you'll need to figure out which ones failed to wind back successfully.

Comment by srujan on 2020-02-12:
Thanks for your suggestion. I made sure rosdep is in the /usr/bin

$\endgroup$
0
$\begingroup$

Rosanswers logo

The fix was very simple, I went to the /usr/local/bin and removed everything related to ROS and Catkin. That resolved my issue. The next time when I installed ros-melodic and did rosdep init, I saw the rosdep files in usr/bin/ and everything worked smooth from there.


Originally posted by srujan with karma: 32 on 2020-02-12

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.