1
$\begingroup$

Rosanswers logo

Hello everyone ! I have ROS 2 setup with cyclone dds as ros middleware implementation on both, my laptop and Jetson Nano. I am following the following link for the QOS setting : https://github.com/eclipse-cyclonedds/cyclonedds/blob/master/docs/manual/options.md#cycloneddsdomaindiscoverytag

Also my config.xml file is as below :

 <?xml version="1.0" encoding="UTF-8" ?>
 <?xml-model href="https://raw.githubusercontent.com/eclipse-cyclonedds/cyclonedds/master/etc/cyclonedds.xsd" schematypens="http://www.w3.org/2001/XMLSchema" ?><CycloneDDS xmlns="https://cdds.io/config">
<Domain Id= "any">
<General>
    <NetworkInterfaceAddress>auto</NetworkInterfaceAddress>
    <AllowMulticast>false</AllowMulticast>
    <EnableMulticastLoopback>true</EnableMulticastLoopback> 
</General>      
<Compatibility>
      <StandardsConformance>lax</StandardsConformance> </Compatibility>    
</Domain> 
</CycloneDDS>

But if I set false the Allow Multicast tag then I am unable to subscribe(from laptop) the topic published on my own laptop. I have been trying to solve it out by setting other tags but everytime it fails . I am using publisher and subscriber code from the demo_nodes_py package of the ros2.

Ubuntu : 18.04 ROS2 Distro : Dashing


Originally posted by charvi on ROS Answers with karma: 50 on 2020-01-21

Post score: 2

$\endgroup$

1 Answer 1

1
$\begingroup$

Rosanswers logo

Maybe you should set Peer Address when multicast is disabled.

Otherwise, you can set spdp instead of false.


Originally posted by Ting.Chang with karma: 16 on 2020-01-26

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.