0
$\begingroup$

Rosanswers logo

I would like to install ROS Kinetic on my Raspberry PI4 using Raspbian Buster:

PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

But following the instruction here => https://wiki.ros.org/ROSberryPi/Installing%20ROS%20Kinetic%20on%20the%20Raspberry%20Pi When I type this line => sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/kinetic

I got this output:

==> Processing catkin package: 'qt_gui_cpp' ==> Building with env: '/opt/ros/kinetic/env.sh' Makefile exists, skipping explicit cmake invocation... ==> make cmake_check_build_system in '/home/pi/ros_catkin_ws/build_isolated/qt_gui_cpp' ==> make -j4 -l4 in '/home/pi/ros_catkin_ws/build_isolated/qt_gui_cpp' [ 83%] Built target qt_gui_cpp [ 88%] Compiling generated code for qt_gui_cpp_sip Python bindings... make[3]: warning: jobserver unavailable: using -j1. Add '+' to parent make rule. /usr/bin/ld: cannot find -lcatkin::rosconsole::wrapped-linker-option0 /usr/bin/ld: cannot find -lcatkin::rostime::wrapped-linker-option0 collect2: error: ld returned 1 exit status make[3]: * [Makefile:38: "/home/pi/ros_catkin_ws/devel_isolated/qt_gui_cpp/lib/python2.7/dist-packages/qt_gui_cpp/libqt_gui_cpp_sip".so] Error 1 make[2]: *[src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/build.make:61: /home/pi/ros_catkin_ws/devel_isolated/qt_gui_cpp/lib/python2.7/dist-packages/qt_gui_cpp/libqt_gui_cpp_sip.so] Error 2 make[1]: * [CMakeFiles/Makefile2:566: src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/all] Error 2 make: * [Makefile:141: all] Error 2 <== Failed to process package 'qt_gui_cpp': Command '['/opt/ros/kinetic/env.sh', 'make', '-j4', '-l4']' returned non-zero exit status 2

Reproduce this error by running: ==> cd /home/pi/ros_catkin_ws/build_isolated/qt_gui_cpp && /opt/ros/kinetic/env.sh make -j4 -l4

Command failed, exiting.

Because I didn't find anything that can solve my issue, I would be glad if I can have any help!


Originally posted by MCmobil on ROS Answers with karma: 33 on 2020-01-06

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I have found the error, the rqt_gui_cpp doesn't compile so I changed it completely and clone the one existing on git by doing this:

cd /home/pi/ros_catkin_ws/src

sudo rm -rf python_qt_binding

git clone https://github.com/ros-visualization

Maybe the one previously downloaded is obsolete...? anyway it has solved this part!


Originally posted by MCmobil with karma: 33 on 2020-01-07

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by Marnett5 on 2020-02-25:
This did work, though unfortunately I have another issue with the OGRE package not being found, with a different version of Libboost needed for the installation. I'm stuck here at the moment if you want to help out.

Comment by MCmobil on 2020-02-25:
Hi Marnett5, Yes I will try! It has been a while I haven't touched it, for now I don't have access to the Raspberry but I may have it back soon. Anyway would you provide me the steps you have done? It will help me to remind and understand where it is blocking. Thanks!

Comment by espenseventyr on 2020-02-26:
Yes that worked for me too, thanks (git clone https://github.com/ros-visualization/python_qt_binding). There is an issue with libboost mentioned on http://wiki.ros.org/ROSberryPi/Installing%20ROS%20Kinetic%20on%20the%20Raspberry%20Pi under section 3.3. Did you see that? I'm compiling now but seems like this will work for the desktop install. For the desktop_full the conflict seems unresolvable, I'll add packages as I need them beyond the desktop install.

Comment by MCmobil on 2020-02-26:
Yes I could remember it. I haven't faced that issue because I took only a light version of ROS (I wanted to use something light but efficient). Maybe the desktop_full version assuming using some libraries that are not obviously used by the Pi?

Comment by Marnett5 on 2020-02-27:
I had some issues with OGRE when installing the desktop version, but had no problem installing the light version. However, I gave up when trying to install turtlebot 2 packages; too many brick walls with that thing.

Comment by MCmobil on 2020-02-28:
Hmmm I would advise to start a new thread. You can make reference to this post, but I think it will be easier and cleaner to not do it here. Open it and I will help you there!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.