0
$\begingroup$

Rosanswers logo

Hello all,

I am having problems with RTABMAP (0.19.3) in ROS Melodic. I am using a stereo camera setup on a simulated car in gazebo.

Here are four images that visualize my problem: link

The first two are before the car moves and the other two after the car moved.

As can be seen only the nearest detected points are used to generate the projected 2D Map and hence the 3D map does so too.
Is there a parameter that specifies the maximum allowable depth?
Here is a link to the launchfiles: link

I also tried it with RGBD data provided by stereo_image_proc but got the same results.

Thank you very much for your help.


Originally posted by GeorgNo on ROS Answers with karma: 183 on 2019-12-17

Post score: 1


Original comments

Comment by matlabbe on 2020-01-07:
Do you have a database to share? (~/.ros/rtabmap.db). In rtabmapviz, is Map column under Preferences->3D Rendering is checked? There are images shown under loop closure detection panel, so mapping seems working, normally a 3D map would be assembled.

Comment by GeorgNo on 2020-01-14:
Thank you for your answer. Map is checked under Preferences->3D Rendering. But the problem seems to be that "Maximum depth" is set to "4" on default although I put

<param name="Kp/MaxDepth"                       type="string" value="0"/>
<param name="Vis/MaxDepth"                      type="string" value="0"/>   <!-- 0 Means no limit (inf) -->

in my launchfile. Is the Maximum depth parameter called different?

Comment by matlabbe on 2020-01-14:
3D rendering parameters in Preferences are related to rtabmapviz only (they don't affect how data are saved in the database, just how they are rendered), not rtabmap. Kp/MaxDepth and Vis/MaxDepth affect only visual feature extraction, they don't affect how clouds are created in rtabmapviz. It could be easier to debug if you have a rtabmap.db to share.

Comment by GeorgNo on 2020-01-15:
Hello. Here is a link to the databse: link . Thank you for your help

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Data seem there. Here what I did to show the 3D map:

$ rosrun rtabmap_ros rtabmap _database_path:="~/Downloads/rtabmap.db"
$ rosrun rtabmap_ros rtabmapviz
$ rviz /rtabmap/get_map_data:=/get_map_data

For rtabmapviz, make sure the Map column is checked in Preferences->3D Renderings and maximum depth is 0: image description

Close Preferences and click Download all clouds: image description

For rviz, with MapCloud plugin, make sure Max Depth is 0, then click on Download: image description

cheers,
Mathieu


Originally posted by matlabbe with karma: 6409 on 2020-01-15

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by GeorgNo on 2020-01-20:
Thanks for your help Mathieu,

if I use the MapCloud plugin I now can display the generated map as seen in the last picture of your post.

But if I want to display the 2D (topic: /rtabmap/grid_map) or 3D (topic: /rtabmap/cloud_map) map it still does not work the way I except it to do. Please see this image.

It only generates the map ~4m ahead of the stereo camera.

All the best, Georg

Comment by matlabbe on 2020-01-20:
Change parameter Grid/RangeMax (default 5 meters). You may also want to update Grid/CellSize (default 0.05 meters) to like 0.3.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.