0
$\begingroup$

Rosanswers logo

I am an absolute beginner to Ubuntu and ROS and to such q/a forums, so please be forgiving. I am using Ubuntu 18.04.3 and running ROS Melodic. I am following an old Udacity course archive. It is about a package called simple_arm which I cloned from (https://github.com/udacity/simple_arm_01.git )

I have created my catkin workspace, initialized it, cloned from github, ran catkin_make, sourced bash.setup as according to instructions. However I get an error when run the launch command:

roslaunch simple_arm robot_spawn.launch

The error i receive is:

... logging to /home/karthik/.ros/log/5ae6a64a-c58b-11e9-8b56-34e6ad8bdd6e/roslaunch-UnitedForever-17751.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

xacro: in-order processing became default in ROS Melodic. You can drop the option.
substitution args not supported:  No module named 'rospkg'
when processing file: /home/karthik/catkin_ws/src/simple_arm/urdf/simple_arm.urdf.xacro
RLException: while processing /home/karthik/catkin_ws/src/simple_arm/launch/robot_description.xml:
Invalid <param> tag: Cannot load command parameter [robot_description]: command [/opt/ros/melodic/lib/xacro/xacro --inorder '/home/karthik/catkin_ws/src/simple_arm/urdf/simple_arm.urdf.xacro'] returned with code [2]. 

Param xml is <param command="$(find xacro)/xacro --inorder &apos;$(find simple_arm)/urdf/simple_arm.urdf.xacro'" name="robot_description"/>
The traceback for the exception was written to the log file

Originally posted by karburettor on ROS Answers with karma: 96 on 2019-08-23

Post score: 3


Original comments

Comment by ffusco on 2019-08-23:
Did you change anything from the code? I just cloned the repo and it works for me...

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

I had installed Anaconda. It had changed some python path. Uninstalling it and running above code solved the error. Thanks.


Originally posted by karburettor with karma: 96 on 2019-08-25

This answer was ACCEPTED on the original site

Post score: 5


Original comments

Comment by Rahul K R on 2020-02-05:
I faced the same error. Fixed it by uninstalling anaconda3 Thanks!

Comment by sia on 2020-04-03:
I faced the same error however instead of uninstalling Anaconda I install rospkg with Anaconda by running conda install -c conda-forge rospkg (got this from https://anaconda.org/conda-forge/rospkg). This way you don't have to uninstall Anaconda

Comment by fabbro on 2020-06-02:
I am using virtualenvironment instead of anaconda. Do you have any suggestions on how to solve this error?

Comment by PavanMV on 2021-07-03:
you can deactivate your conda/venv environment. Now its looks for system-level python instead of your environment.

$\endgroup$
0
$\begingroup$

Rosanswers logo

I was getting the same error. The issue was that I was in a virtual environment. If your in one that's likely the issue - just run deactivate / conda deactivate


Originally posted by jstm with karma: 21 on 2022-12-16

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.