0
$\begingroup$

Rosanswers logo

I've just installed melodic on OSX and wonder if I've done it right as I've had to make a few changes. I've tried running rosversion ros, but I get Cannot locate [ros]. The command source /opt/ros/melodic/setup.bash inside /opt/ros/melodic gives no result. The command roscore gives the following:

started roslaunch server http://mun-iMac.local:53241/ ros_comm version 1.14.3

SUMMARY

========

PARAMETERS * /rosdistro: melodic * /rosversion: 1.14.3

NODES

auto-starting new master process[master]: started with pid [11220] ROS_MASTER_URI=http://mun-iMac.local:11311/

setting /run_id to fdde4302-c046-11e9-ae5e-b06ebf60167b process[rosout-1]: started with pid [11223] started core service [/rosout]

Does anyone know if it's properly installed?


Originally posted by mun on ROS Answers with karma: 32 on 2019-08-16

Post score: 0

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

Why should it not be installed correctly? You can easily try to start a node, such as turtlesim and see if it works (rostopic echo /topicname -> to see if current data are in the topic)


Originally posted by Horst with karma: 38 on 2019-08-16

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by mun on 2019-08-16:
I've had to change quite a few things to get it running on OSX, so I wasn't quite sure. All good now! Thanks

$\endgroup$
0
$\begingroup$

Rosanswers logo

By looking at your roscore output, your ros is up and running and also you can see the version number in the parameters. For getting an output to rosversion, try checking the version of the basic ros packages. You can type rosversion roscpp.


Originally posted by ksb with karma: 36 on 2019-08-16

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.