Rosanswers logo

I have been trying to use Autoware to map a large area ( bag file of 5.3 GB). After the mapping has been done, i output the pcd map according to https://github.com/autowarefoundation/autoware/issues/1207?source=post_page---------------------------

After i output the map, when i tried using the .pcd file in the map tab, on the console it said "failed "Path_to_pcd_file"" and only map a part of the map that were supposed to be created. Has anybody had this problem before and if so how do i fix it? I suspect that it is because the output map is quite large (253.MB), as i was trying to map with smaller maps before and autoware worked fine.

Thanks in advance


For the pcd file, you can find it here I am using:

  • autoware 1.10.0
  • Ubuntu 16.04

I installed ros from source, following the instruction in this link and i am not using docker.

Originally posted by hoang khac on ROS Answers with karma: 3 on 2019-07-25

Post score: 0

Original comments

Comment by Yamato Ando on 2019-07-26:
Would you please share a screenshot of the console showing the error? And if possible, please share your .pcd file.

Comment by Josh Whitley on 2019-07-26:
We also need to know which version of Autoware you are using, what version of Ubuntu, how you installed ROS (source or from apt), and whether or not you are using Docker.

Comment by hoang khac on 2019-07-26:
Hi, Thank you all for answering to my question. I am very new to this so excuse me for the newbie's mistake For the pcd file, you can find it on https://drive.google.com/file/d/1mZaWlnoxCkZJBvKCnlMGvePOl3nCk2YU/view?usp=drivesdk I am using autoware 1.10.0 on Ubuntu 16.04. I installed ros from source, following the instruction in this link and i am not using docker. Unfortunately, i am not with my laptop at the moment and can not provide the console of the error. I really do appreciate if anybody has any advices.

Comment by jayess on 2019-07-26:
@hoang khac I've edited your question to include the information from your comment so that it's easier to find


1 Answer 1


Rosanswers logo

Thank you for sharing PCD.

It seems that the number of point clouds written in the header of the file is different. Please open autowre-190725.pcd with an editor and rewrite WIDTH and POINTS from 35006911 to 8080162.

Originally posted by Yamato Ando with karma: 231 on 2019-07-26

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by hoang khac on 2019-07-27:
Thank you very much i will try that once i get back

Comment by hoang khac on 2019-07-31:
Thank you so much. It now has worked output the correct answers.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.