0
$\begingroup$

Rosanswers logo

Hello, I'm trying to add Rviz to ROS Kinetic 1.12.12, but there isn't instructions for this version on the user's guide.

I tried to run sudo apt-get install ros-kinetic-rviz but the console says it's "Unable to locate package ros-kinetic-rviz".

Is there something i'm missing ?

Thank you for your replies, have a good day.


(edit)

I forgot to mention i am using a Raspberry Pi3 with Raspbian stretch, that might not help... So I ran the sudo apt update and i had the same errors as in #q325039. I followed the steps, now everything is normal I have the following output :

pi@raspberrypi:~ $ sudo apt-get update
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
Hit:3 http://packages.ros.org/ros/ubuntu stretch InRelease
Reading package lists... Done

But i am still unable to locate the ros-kinetic-rviz package :(

And uname -a gives me :

Linux raspberrypi 4.9.59-v7+ #1047 SMP Sun Oct 29 12:19:23 GMT 2017 armv7l GNU/Linux

I didn't installed ROS myself, i flashed an image i found here on my SD card because i could not build all the libraries on my Pi (not enough RAM...). It looks like it has been installed from sources on the website, so i would like to try to build rviz from sources but have no idea how to do that.


Originally posted by goowza on ROS Answers with karma: 16 on 2019-07-08

Post score: 0


Original comments

Comment by gvdhoorn on 2019-07-08:
Please post the output of sudo apt update and check whether you're running into #q325039.

Also: please show us the output of uname -a.

Comment by gvdhoorn on 2019-07-09:\

Okay i forgot to mention i am using a Raspberry Pi3 with Raspbian stretch

yes, that is important information to share. And also why I asked for the output of uname -a.

Comment by gvdhoorn on 2019-07-09:
How did you install ROS? Using apt or building everything from source?

If the latter: you cannot mix apt with from-source builds.

Additionally: I'm not entirely sure, but I don't know whether there are binary packages available of ROS Kinetic for RPi's with Raspbian (Stretch).

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Okay, I realized the ROSberry page provided a link to download an SD Card Image with Ubuntu 16.04 (LXDE) and ROS Kinetic installed. Rviz is already installed on this image and runs normally, so my problem is fixed ! I wish i saw that earlier haha :v

Thank you for your answers !


Originally posted by goowza with karma: 16 on 2019-07-09

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.