0
$\begingroup$

Rosanswers logo

ENV: Autoware 1.11.1 and 1.12.alpha1,2 ROS1. Cross compile generic-aarch64 is OK, but cross compile driveworks always got error,

log:

--- stderr: ndt_gpu
CMake Warning at /sysroot/driveworks/opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:76 (find_package): Could not find a package configuration file provided by "autoware_build_flags" with any of the following names:

autoware_build_flagsConfig.cmake
autoware_build_flags-config.cmake

Add the installation prefix of "autoware_build_flags" to CMAKE_PREFIX_PATH or set "autoware_build_flags_DIR" to a directory containing one of the
above files. If "autoware_build_flags" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first):

CMakeLists.txt:4 (find_package)

CMake Error at /sysroot/driveworks/opt/ros/kinetic/share/catkin/cmake/catkinConfig.cmake:83 (find_package): Could not find a package configuration file provided by "autoware_build_flags" with any of the following names:

autoware_build_flagsConfig.cmake
autoware_build_flags-config.cmake

Add the installation prefix of "autoware_build_flags" to CMAKE_PREFIX_PATH or set "autoware_build_flags_DIR" to a directory containing one of the
above files. If "autoware_build_flags" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first):
CMakeLists.txt:4 (find_package)

--- Failed <<< ndt_gpu [ Exited with code 1 ]


Originally posted by sdyy on ROS Answers with karma: 26 on 2019-07-04

Post score: 0


Original comments

Comment by sdyy on 2019-07-04:
I may know why is failed, because after colcon build, some packages were not installed. But I don't know why there were not installed

Comment by Josh Whitley on 2019-07-05:
@sdyy - Can you please try the version on the master branch of autoware? Please post the output of the following commands inside your autoware folder:

git remote get-url origin
cd ros && ls && cd ..

Please be aware: The colcon_release_cross still expects all of the dependent repositories to be in the ros/ folder.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I found this issue is caused by cross_toolchain_driveworks.cmake

set(CMAKE_PREFIX_PATH "${CMAKE_SYSROOT}/opt/ros/kinetic")

mark this line will be OK.

By the way, if want to build all packages, will be still fail. In driveworks docker image, it leaks some packages, need to install.


Originally posted by sdyy with karma: 26 on 2019-07-08

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.