0
$\begingroup$

Rosanswers logo

Hello I have a raspberyy pi 3b+ with ARMv7 Processor (64bit). I have followed the ROS Melodic installation instruction from the http://wiki.ros.org/melodic/Installation/Ubuntu.

Robotic_arm@Robotic_arm-desktop:~$ sudo sh -c 'echo "deb http://packages.ros.org/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'
[sudo] password for Robotic_arm: 

Robotic_arm@Robotic_arm-desktop:~$ sudo apt-key adv --keyserver 'hkp://keyserver.ubuntu.com:80' --recv-key C1CF6E31E6BADE8868B172B4F42ED6FBAB17C654
Executing: /tmp/apt-key-gpghome.HQv1zUHfW7/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-key C1CF6E31E6BADE8868B172B4F42ED6FBAB17C654
gpg: key F42ED6FBAB17C654: public key "Open Robotics <[email protected]>" imported
gpg: Total number processed: 1
gpg:               imported: 1

Robotic_arm@Robotic_arm-desktop:~$ sudo apt update
Hit:1 http://ports.ubuntu.com bionic InRelease                                 
Hit:2 http://ppa.launchpad.net/ubuntu-pi-flavour-makers/ppa/ubuntu bionic InRelease
Ign:3 http://packages.ros.org/ubuntu bionic InRelease                   
Get:4 http://ports.ubuntu.com bionic-updates InRelease [88.7 kB]        
Err:5 http://packages.ros.org/ubuntu bionic Release                            
  404  Not Found [IP: 2600:3402:200:227::2 80]
Get:6 http://ports.ubuntu.com bionic-security InRelease [88.7 kB]              
Hit:7 http://ports.ubuntu.com bionic-backports InRelease      
Hit:8 http://ports.ubuntu.com/ubuntu-ports bionic InRelease
Get:9 http://ports.ubuntu.com bionic-updates/main armhf Packages [490 kB]
Get:10 http://ports.ubuntu.com bionic-updates/universe armhf Packages [800 kB]
Get:11 http://ports.ubuntu.com bionic-updates/universe Translation-en [279 kB] 
Reading package lists... Done                                    
E: The repository 'http://packages.ros.org/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Robotic_arm@Robotic_arm-desktop:~$ sudo apt install ros-melodic-desktop-full
[sudo] password for Robotic_arm: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-melodic-desktop-full

Robotic_arm@Robotic_arm-desktop:~$ 

Can you please let me know how I can overcome this issue?? Thank you very much!


Originally posted by Robotic_arm on ROS Answers with karma: 3 on 2019-06-11

Post score: 0


Original comments

Comment by gvdhoorn on 2019-06-11:
You first write that you're looking to install 32-bit software, then state that your processor is 64-bit. What is it that you actually want to do?

Comment by tfoote on 2019-06-11:
Please edit your question to include the full commands you ran and the complete error message. Also please make sure to use copy and paste not type out error messages as accurate reproduction is important for us to help you debug.

Comment by Robotic_arm on 2019-06-11:
@gvdhoorn: Sorry if I wasn't clear. I have Ubuntu 18.04.2 which is 32 bit. But my raspberry pi has arm processor which is 64 bit.

Comment by gvdhoorn on 2019-06-11:
@Robotic_arm: note @tfoote's answer: you have packages.ros.org/ubuntu, it's packages.ros.org/ros/ubuntu. Note the ros after packages.ros.org there.

Comment by Robotic_arm on 2019-06-11:
@gvdhoorn: yes thank you! I realized it as i was copy pasting the entire list of commands.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

You appear to have copy and pasted the wrong url from the tutorial.

The repository is at: http://packages.ros.org/ros/ubuntu not http://packages.ros.org/ubuntu


Originally posted by tfoote with karma: 58457 on 2019-06-11

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Robotic_arm on 2019-06-11:
Thank you very much for your help!!

Comment by tfoote on 2019-06-11:
Please accept the answer using the check mark at the left so others know you have a solution.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.