0
$\begingroup$

Rosanswers logo

Hi,

I am very new to ROS. I am trying to replay a recorded bag file containing point cloud2 topic with map as the fixed frame and my lidar unit as the reference frame in simulation time but I am receiving a status error under the pointcloud2 mentioning

Transform[sender=unknown publisher] message removed because it is too old (frame=[/os1_lidar ], with an ongoing timestamp which is different from both of my ros time and wall time. my wall time and ros time ar running aligned.

I have tried to replay the pointcloud2 topic with both in false and true sim_time it does not work and coming up with the same error. However, when I am putting base_link(lidar unit) as both the reference and the fixed frame it's replaying the pointcloud2 topic. But I need to visualize it with map as the fixed frame and base_link(lidar) as the reference frame.

May I know whether I can upload any picture regarding my problem.

Thank you for your time.


Originally posted by Dina on ROS Answers with karma: 1 on 2019-06-06

Post score: 0


Original comments

Comment by gvdhoorn on 2019-06-06:\

Possible reasons are listed at http://wiki.ros.org/tf/Errors%20explained

have you checked that page?

Comment by Dina on 2019-06-06:
Hi,

Thank you very much for your kind reply. I followed the site.Here is my launch file code.

<!--- TF -->
<node pkg="tf2_ros" type="static_transform_publisher" name="camera_init_to_map"  args="0 0 0 1.570795   0        1.570795 map    camera_init" />
<node pkg="tf2_ros" type="static_transform_publisher" name="base_link_to_camera" args="0 0 0 -1.570795 -1.570795 0        camera base_link" />
<node pkg="tf2_ros" type="static_transform_publisher" name="baselink_to_os1sensor" args="0 0 0 0 0 0  base_link os1_sensor"/>

<!--- LeGO-LOAM -->    
<node pkg="lego_loam" type="imageProjection"    name="imageProjection"    output="screen"/>
<node pkg="lego_loam" type="featureAssociation" name="featureAssociation" output="screen"/>
<node pkg="lego_loam" type="mapOptmizatio

Comment by Dina on 2019-06-06:
But I am still getting the same error. I set up the simulation time as true following the site.

In my RVIZ when I am trying to add the pointcloud2 topic from a recorded bag file with map as the fixed frame. it's saying

"Transform [sender=unknoiwn publisher] Message removed because it is too old"

my errors are like as follow while running the "rqt_tf_tree" in the terminal-

[WARN] [1559879011.540520, 1559630326.265300]: Detected jump back in time of 61.937579s. Clearing TF buffer. Warning: TF_OLD_DATA ignoring data from the past for frame laser_odom at time 1.55963e+09 according to authority /featureAssociation Possible reasons are listed at http://wiki.ros.org/tf/Errors%20explained at line 277 in /tmp/binarydeb/ros-kinetic-tf2-0.5.20/src/buffer_core.cpp

Can you please recommend a possible solution to resolve this problem ?

Thanks Dina

Comment by gvdhoorn on 2019-06-07:
Please do not post this sort of update in a comment. Edit your original question.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This can be caused by a variety of reasons which only you can really debug. I would suggest trying the following:

rosparam set use_sim_time true

To make sure nodes use the /clock topic for time and run you bag using

rosbag play --clock [your bag here]

Originally posted by JustinBlack02 with karma: 131 on 2019-06-08

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.