Rosanswers logo


I'm working on Jackal from Clearpath. The robot came with indigo and after a while, I re-imaged it. Now everything is working fine except LiDAR. When I run rostopic list it doesn't show /front/scan in a list. It was showing it before re-imaged the robot.
for running the LiDAR I follow these steps:

  1. sudo apt-get install ros-indigo-lms1xx
  2. cd /opt/ros/indigo/share/lms1xx/launch
  3. sudo cp LMS1xx.launch /etc/ros/indigo/ros.d/

After the above steps I connected the robot to Access Point since our university lab has some IT restriction and it doesn't let me access the robot with SSH.

Immediately after re-imaging the robot the rostopic list shows the /front/scan but when I run rostopic echo /front/scan didn't show any update. I did somthing and it got even worth which dosn't show in rostopic list output.

I connect to the robot with my cellphone hot spot the IPs are :

Robot IP:
Host IP:     


and run the LMS1xx.launch and below are the outputs:

administrator@PNW-ECE:/opt/ros/indigo/share/lms1xx/launch$ ls
administrator@PNW-ECE:/opt/ros/indigo/share/lms1xx/launch$ roslaunch LMS1xx.launch 
... logging to /home/administrator/.ros/log/40850f36-4830-11e9-82ab-59833ebd9fa1/roslaunch-PNW-ECE-25769.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server


 * /lms1xx/host:
 * /rosdistro: indigo
 * /rosversion: 1.11.21

    lms1xx (lms1xx/LMS1xx_node)


core service [/rosout] found
process[lms1xx-1]: started with pid [25799]

I also don't know how can I activate the Lidar node. It seems the node is not activated yet.

Any Help would be appreciated.

Thank you

Update: When I run below command in one terminal, I can see the /front/scan in my rostopic list in another terminal.

roslaunch jackal_navigation gmapping_demo.launch

but still I can't see the output of the lidar.

Originally posted by imanpakii on ROS Answers with karma: 26 on 2019-03-17

Post score: 0

Original comments

Comment by ahendrix on 2019-03-19:
I don't know anything about this particular ROS node, but I would try to get it working with rosrun before trying to set up launch files for autostart.

Comment by mgruhler on 2019-03-20:
maybe some more information about what exactly you did do when you "re-imaged" it might also be helpful. Did you use a provided image? Did you manually install stuff? ...

Comment by imanpakii on 2019-03-20:
Hi Thank you for your response. I re-imaged with the provided image from clearpath, and I install Lidar stuff myself.

Thank you

Comment by mgruhler on 2019-03-21:
just a few pointers, but I'm lost about what could be your issue:

  • check that the IP of the LMS is actually
  • why do you think you have to activate the lidar? The driver should do this for you, if the connection is right...
  • what's that thing with your cellphone hotspot? You are running all those commands on the robot PC itself (connected via ssh), correct?

Comment by imanpakii on 2019-03-21:
Hello @mgruhler 1-Thank you for your response. I checked it with SICK LIDAR software and also when I ping it, it response me back. when I disconnect it, the ping is not working. 2- because when I run rostopic list it does not appear to the list. but when I run for example roslaunch jackal_navigation gmapping_demo.launch and in another terminal do the rostopic list, I can see the /front/scan topic in a list. that's why I think it's not activated. 3- yes I do, but because our university lab has some restrictions in terms of security, the SSH connection doesn't work correctly all the time and also the IP address always change and we need to connect the cable to the robot for obtaining the IP address. That's why We set up an Access point, and if I want to download any packages in the robot I can't do that with AP then I connect my robot and my PC through my cell hot spot together.

Thank you for your help Iman

Comment by billy on 2019-03-21:
Just a thought I have when I see reports of things working and not working regarding topics. If you're starting and stopping nodes, makes sure that you have roscore running when you start a node. If you kill roscore and restart it, it will lose track of nodes that were running until they have been restarted as well.

Comment by imanpakii on 2019-03-22:

I think the roscore is working since another rostopic working properly. for example odometry or IMU or camera, they appear in rostopic list and also when I do the rostopic echo <topic> they are showing the raw data.

Thank you

Comment by ahendrix on 2019-03-24:
Does the lidar node work if you run it manually with rosrun: rosrun lms1xx LMS1xx_node _host:= ?

Comment by imanpakii on 2019-03-24:

Thank you for your comment. I can check it tomorrow when I go to lab, but what will it can tell us if it's work or not? Thank you

Comment by ahendrix on 2019-03-24:
You may get an error message indicating that it wasn't able to connect, or a message saying that it did, or it may crash. It may also print the topic that it's publishing to. In any of those cases, I'm hoping that it helps you figure out whether the issue is your hardware, a software issues, or a configuration problem.

Comment by gvdhoorn on 2019-03-25:
@imanpakii: could you please not edit your post just to bump it? The last two edits don't seem to actually add anything to your post.

Comment by imanpakii on 2019-03-27:
@ahendrix Hello,

Please see the output below:

rosrun lms1xx LMS1xx_node _host:=

[ INFO] [1553638617.627167916]: Connecting to laser at
[ INFO] [1553638617.642444928]: Connected to laser.

I also run the below command as well:

echo /front/scan
WARNING: topic [/front/scan] does not appear to be published yet

Thank you Iman

Comment by mgruhler on 2019-03-27:
If you just rosrun this node, it will publish the topic to /scan. This is actually what the launch file is doing as well. There is no remapping in there. Could it be that the driver is working all along, publishing to /scan and /front/scan is showing up because something is subscribing to that?

To confirm, run the following commands:

rostopic info /scan
rostopic info /front/scan
rosnode info /lms1xx

1 Answer 1


Rosanswers logo

This issue finally fixed by adding the JACKAL_LASER=1 parameter in the setup file in /etc/ros/setup.bash. (Thanks to ClearPath Robotic supports and engineers). By adding that parameter the laser read from topic /front/scan instead of /scan. before I added this parameter, gmapping looking for /front/scan and the laser topic published in /scan Thank you everyone who tried to help me.

Thank you Iman

Originally posted by imanpakii with karma: 26 on 2019-03-27

This answer was ACCEPTED on the original site

Post score: 0

Original comments

Comment by ahendrix on 2019-03-27:
It looks like the jackal launch file also launches the lms1xx driver with the proper topic remapping if JACKAL_LASER is set: https://github.com/jackal/jackal_robot/blob/567c07f83640c064efaf20f3df3c65db49c5ffbc/jackal_bringup/launch/accessories.launch#L9-L15 . Copying LMS1xx.launch to /etc/ros/indigo/ros.d/ seems completely unnecessary.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.