0
$\begingroup$

Rosanswers logo

Hello,

I'm trying to setup a workstation to work with a Turtlebot.

I've followed the tutorial here : wiki.ros.org/Robots/Turtlebot/Network%20Setup

Robot IP is : 192.168.0.152 Workstation IP is 192.168.0.122

In .bashrc I set up ROS_MASTER_URI in both bashrc at this value : http://192.168.0.152:11311 Both Hostname are set up with the IP of the machine

I can ping in both ways.

Roscore is launched on the robot and rostopic return "/rosout" and "/rosout_agg" But still when I launch "rostopic list" on the workstation, it doesn't work and returns "Unable to connect with master"

Has someone any leads that we could follow please?

Thank you :D


Originally posted by gautier on ROS Answers with karma: 16 on 2019-03-12

Post score: 0


Original comments

Comment by billy on 2019-03-12:
Have you set the IP of the workstation as ROS id? If workstation isn't properly identified, roscore can't connect it to the topic.

"export ROS_IP=192.168.0.122" in the bashrc file on the workstation?

Comment by gautier on 2019-03-13:
hello, thanks for your answer but the bashrc file already have "export ROS_IP=192.168.0.122" have you other ideas ?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

got it !! it was the firewall of the machine link to the robot thanks for your help anyway


Originally posted by gautier with karma: 16 on 2019-03-13

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.