0
$\begingroup$

Rosanswers logo

Hello Everyone! At first, sorry for my English :( I`ve got a problem. I'm beginner at ROS (melody, ubuntu 18.04). I learing how to do a URDF file, i'm using this tutorial: https://www.youtube.com/watch?v=Ale55LcdZeE&list=PLK0b4e05LnzaY2QxaTHkvLJPNVNx-ssDW&index=24 .

When i start rviz a only see a base_link (without link_01), I try to change URDF file but it doesn`t helped. this is my xacro file:

<?xml version="1.0" ?>

<robot name="mrm" xmlns:xacro="http://www.ros.org/wiki/xacro">
    <link name="base_link">
    <visual>
      <origin rpy="0 0 0" xyz="0 0 0" />
      <geometry>
        <box size="1 1 1" />
      </geometry>
    </visual>
    </link>

      <joint name="base_link__link_01" type="revolute">
    <axis xyz="0 0 1"/>
    <limit effort="1000.0" lower="-3.14" upper="3.14" velocity="0.5"/>
    <origin rpy="0 0 0" xyz="0 0 0.5"/>
    <parent link="base_link"/>
    <child link="link_01"/>
      </joint>

    <link name="link_01">
    <visual>
      <origin rpy="0 0 0" xyz="0 0 0.2" />
      <geometry>
        <cylinder radius="0.35" length="0.4" />
      </geometry>
    </visual>
    </link>
</robot> 

and launch file:

<launch>
    <param name="robot_description" command="$(find xacro)/xacro --inorder '$(find mrm_description)/urdf/mrm.xacro'"/>
    <node name="robot_state_publisher" pkg="robot_state_publisher" type="state_publisher"/>
    <node name="rviz" pkg="rviz" type="rviz"/>
    
    <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher" >
        <param name="use_gui" value="True"/>
    </node>
</launch>

i would be very grateful for Your help! Pawel :)


Originally posted by Pawel_www on ROS Answers with karma: 63 on 2019-03-04

Post score: 0


Original comments

Comment by SleepyTurtle on 2019-03-05:
I've copied your setup and it works fine for me. Maybe you're not setting up rviz correctly? What do you mean by "only see a base_link (without link_01)"?

Comment by Pawel_www on 2019-03-05:
Hey! Thank You for Your answer! i change the value of radius(more than one), and value of length(also more than one) and it`s works(i see base_link and link_01)! but when i change this value (radius and length<1), the cylinder(link_01) disappears :(

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This is most likely a locale problem. If you've not configured your machine to use en_US.UTF-8, the urdf parser will try to use commas (,) for floating point nrs, and you're using dots (.).

See #q272692 for an older duplicate.

Note: just to clarify: this is an issue with urdfdom. The solution is not to override locale everywhere, that would be just a work-around.

See the linked duplicate for more information.


Originally posted by gvdhoorn with karma: 86574 on 2019-03-05

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Pawel_www on 2019-03-06:
Thank You a lot!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.