0
$\begingroup$

Rosanswers logo

I'm running ROS2 Crystal on Ubuntu 18.04. I've installed the ros-crystal-rosbag2 package, but am not sure how to run it. From the Github readme it looks like this should add a verb to the ROS2 command, but when I run:

ros2 bag record -a

I get the following error:

usage: ros2 [-h] Call `ros2 <command> -h` for more detailed usage. ...
ros2: error: argument Call `ros2 <command> -h` for more detailed usage.: invalid choice: 'bag' (choose from 'daemon', 'extension_points', 'extensions', 'launch', 'lifecycle', 'msg', 'multicast', 'node', 'param', 'pkg', 'run', 'service', 'srv', 'topic')

How do I run rosbag2 in Crystal?

Thanks,

David


Originally posted by david.hodo on ROS Answers with karma: 395 on 2019-03-02

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Please make sure to follow the debian instructions correctly: https://github.com/ros2/rosbag2#debian-packages

So in particular, the package you installed does only support the API for rosbag2. The actual command line verb gets added by ros-crystal-ros2bag.


Originally posted by Karsten with karma: 643 on 2019-03-03

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by david.hodo on 2019-03-05:
Thanks. That fixed it. Having a ros2bag and rosbag2 package is somewhat confusing. Is there any documentation on the difference in the two?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.