0
$\begingroup$

Rosanswers logo

Greetings,

I'm a newbie and have an Ubuntu 14.04 computer with ROS indigo loaded on it. I was trying to install ros-indigo-navigation, where I encountered dependency issues. I tried various suggestions and nothing worked. So, I decided to uninstall ROS and reinstall the full desktop version from the beginning. I am having trouble even uninstalling ROS.

for sudo apt-get remove ros-* or for sudo apt-get purge ros-* I get the error saying that Unable to locate package ros-apt.txt and couldn't find any package by regex 'ros-apt.txt'

I did find a file by that name in my home directory though. Any suggestions on how to overcome this and help me reinstall ROS-indigo is very much appreciated.


Originally posted by kkulkarn on ROS Answers with karma: 3 on 2019-02-19

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The shell will expand * as a file wildcard, so it doesn't get passed to apt.

If you don't want the shell to do any file expansions, use single quotes around the arguments you don't want expanded:

sudo apt-get remove '^ros-*'

Originally posted by ahendrix with karma: 47576 on 2019-02-19

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by kkulkarn on 2019-02-19:
Brilliant. I don't know why I didn't think of this even though I'm from the UNIX world! Thanks, it worked.

Comment by jayess on 2019-02-19:
You may want to use '^ros-*' to make sure that you only uninstall things starting with ros. I'm not 100% sure about this but I've seen it recommended on this site before

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.