0
$\begingroup$

Rosanswers logo

Hallo.

I try to follow the tutorial urdf Tutorials/ Building a Visual Robot Model with URDF from Scratch

The Problem what I have is that the 3d Objects are not visible. I can only see the arrows of the x/y/z axis at the joints which are moving when I change the values for the joint angle in the Gui of the joint_state_publisher.

I use melodic and I got the files directly from the Github repository. I started with: roslaunch urdf_tutorial display.launch model:=src/urdf_tutorial/urdf/06-flexible.urdf

It seems to be a general issue, because I got the same problem with other downloaded urdf-examples and all urdf files of this tutorial.

Visual in the RobotModel is in the preferences enabled and when I set TF prefix to false, the arrays of the coordinates in the origin of the not visible objects are also not visible.


Originally posted by tommy3001 on ROS Answers with karma: 3 on 2019-01-14

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

You're probably running into something similar to #q272692. For now that still requires a work-around, until the fixes applied to the affected packages have been propagated upstream (they're in Ubuntu/Debian).


Originally posted by gvdhoorn with karma: 86574 on 2019-01-14

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by tommy3001 on 2019-01-14:
Thanks for the Comment.

export LC_NUMERIC="en_US.UTF-8"

before launch solved the problem for me.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.