0
$\begingroup$

Rosanswers logo

Hi all,

I´m trying to run some mapping experiments with a mobile robot on a Ubuntu 16.04 machine with ROS Kinetic and Gazebo 7.

What I did was to define a diff-drive with the following urdf:

https://github.com/JoseJaramillo/lucrezio_simulation_environments/blob/master/urdf/lucrezio.urdf.xacro

and then, to run the simulation I use this launch file:

https://github.com/JoseJaramillo/lucrezio_simulation_environments/blob/master/launch/robot.launch

by doing so, I get a strange behavior, that is, the robot is loaded correctly but from the laser scan it seems that it´s not able to sense objects:

https://ibb.co/PzXpQg9

Can you please explain me what could be the problem, please?

Thanks!


Originally posted by JoseJaramillo on ROS Answers with karma: 16 on 2018-12-27

Post score: 0

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

Try the using the non-GPU version of the laser. Change the line

<sensor type="gpu_ray" name="head_hokuyo_sensor">

to

<sensor type="ray" name="head_hokuyo_sensor">

and replace

<plugin name="gazebo_ros_head_hokuyo_controller" filename="libgazebo_ros_gpu_laser.so">

with

<plugin name="gazebo_ros_head_hokuyo_controller" filename="libgazebo_ros_laser.so">

Originally posted by lovelife with karma: 31 on 2018-12-27

This answer was NOT ACCEPTED on the original site

Post score: 3


Original comments

Comment by lovelife on 2018-12-27:
https://answers.ros.org/question/250556/hokuyo-laser-scanner-not-working-in-gazebo-using-ros-kinetic/?answer=256746#post-id-256746

Comment by utkuolcar on 2020-12-01:
Thank you. Only this option worked for me.

$\endgroup$
0
$\begingroup$

Rosanswers logo

Try the using the non-GPU version of the laser.

Hello! I did that, it didn't work as expected.

However, I solved it by reinstalling-updating the NVIDIA drivers. works like a champ! Thank you anyway!


Originally posted by JoseJaramillo with karma: 16 on 2018-12-27

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.