0
$\begingroup$

Rosanswers logo

I am using a Toyota HSR robot running Ubuntu 16.04 and ROS Kinetic which I am using the Nav stack on. In rviz, when I try to update the robot's pose with the 2D Pose Estimate tool it does not work. I initially had a similar problem with the 2D Nav Goal which I found was because it was publishing nav goals to the wrong topic, but once I set 2D Nav Goal to publish to the topic /goal it began working. I tried doing a similar thing with the 2D Pose Estimate so after running the command:

rostopic list | grep pose

I got a list of topics:

/global_pose
/hsrb/base_pose
/hsrb/pose2D
/initialpose
/laser_2d_correct_pose
/laser_2d_pose
/laser_2d_pose_ref
/robot_pose
/safe_pose_changer/joint_reference

I tried changing the 2D Pose Estimate tool so that it published to each one of these topics and none of them seemed to work. As such, I'm not really sure how to get it to work. Any help would be much appreciated!


Originally posted by dkrivet on ROS Answers with karma: 19 on 2018-09-07

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Do a rostopic info [topic name] on each to find which is being subscribed to by your application. Then change the rviz config to use this topic. You can test yourself in a terminal if its connect by doing a rostopic pub /topic "{msg}" and should see a reaction. After setting in rviz if it still doesn't work, its an rviz problem, not an application issue.


Originally posted by stevemacenski with karma: 8272 on 2018-09-07

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.