0
$\begingroup$

Rosanswers logo

On running move it for my custom robotic arm i am getting the following error

[ERROR] [1534930610.891287885, 28.494000000]: Action client not connected: uvbot_v1/arm_joint_controller/follow_joint_trajectory
[ERROR] [1534930610.891287885, 28.494000000]: Action client not connected: uvbot_v1/arm_joint_controller/follow_joint_trajectory

Can anyone explain how to setup action client? The tutorials are a bit sketchy.


Edit: these are the active action servers:

/execute_trajectory/goal
/move_group/goal
/pickup/goal
/place/goal
/uvbot_v1/arm_controller/follow_joint_trajectory/goal

is there a conflict btw execute_trajectory and follow_joint_trajectory


Originally posted by Robo_Panda on ROS Answers with karma: 47 on 2018-08-22

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

You have to make sure that the MoveIt cofiguration (I'm assuming you're trying to configure MoveIt here, seeing your other questions) corresponds to whatever namespaces and names your action server(s) is (are) using.

That can sometimes be a bit difficult to figure out, but a simple way to get that information (in lieu of a command line actionlib tool) is something like:

rostopic list | grep -i goal

That should provide you with a list of online action servers.

If you've only got your robot driver (or ros_control or gazebo_ros_control stack) running, you should probably see only one or two results.

One of those will be the FollowJointTrajectory action server (you can use rostopic info /name/of/the/action/topic to find out).

Now use that name in your MoveIt controller configuration file.

For more information, see the Low Level Controllers page in the MoveIt documentation. That should make things more clear. Pay attention to the Debugging Information section: it contains an explanation of the differences between the name and action_ns fields, which typically confuse people.


Edit:

these are the active action servers:

/execute_trajectory/goal

This is probably the one you need (but this is a guess, as I don't know how you've setup your system).

/uvbot_v1/arm_controller/follow_joint_trajectory/goal

This is most likely not a server, but MoveIt's client that has created a publisher for that topic (as part of its action client). But as no one is listening, you get the error message that you already showed.

is there a conflict btw execute_trajectory and follow_joint_trajectory

I don't understand your question.


Originally posted by gvdhoorn with karma: 86574 on 2018-08-22

This answer was ACCEPTED on the original site

Post score: 5


Original comments

Comment by Robo_Panda on 2018-08-22:
Do I need feedback from motor to complete the execution? How can i do this in simulation? I am getting this error: Didn't received robot state (joint angles) with recent timestamp within 1 seconds. I get that this is because the robot is not getting info about current state, how to proceed?

Comment by gvdhoorn on 2018-08-22:
These are completely different issues, and not related to the configuration of the action client at all.

If you already have questions about these issues, update those if necessary. If not, post a new question.

Posting follow-up questions in comments like this is not a good practice.

Comment by Robo_Panda on 2018-08-22:
Okay I'll do that. I did not know about this guideline. Anyways I've solved this issue by modifying the moveit trajectory execution launch file. Thanks for the help.

Comment by gvdhoorn on 2018-08-22:\

Anyways I've solved this issue by modifying the moveit trajectory execution launch file.

the launch file?

Not the controller configuration yaml?

Comment by Robo_Panda on 2018-08-22:
Yes the launch file, as the name of the controller was different in both the files.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.