0
$\begingroup$

Rosanswers logo

I try to bring my robot model (which I have developed for kinetic) to work under melodic. Everything works so far (despite some plugin issues where I have already committed a pull request), but not the visualization of the robot model. The xacro description of the robot is here.

rviz visualization under melodic: rviz visualization under melodic

rviz visualization under kinetic: rviz visualization under kinetic

Here are some points which I have investigated already:

  • I've checked the model on the parameter server via rosparam get /amiro1/robot_description under kinetic and melodic and they are identical.
  • The dae model is also valid, because rviz complains when I just manipulate the mesh location.
  • The wired thing is, that the hokuyo dae mesh is visualized under melodic.
  • I also check all rviz debug messages via rqt_logger_level and rviz tells me that the URDF description is loaded correctly.
  • Maybe it is realted to this issue but again, the hokuyo dae is shown, but not my robot.

If one would like to test it, follow these steps:

  1. checkout https://github.com/tik0/amiro_robot.git
  2. checkout https://github.com/tik0/amiro_msgs.git
  3. build and run roslaunch amiro_gazebo amiro_simple_world.launch

Can anyone help me with this issue?


Originally posted by tik0 on ROS Answers with karma: 220 on 2018-07-04

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Other rviz users have encountered a similar issue at https://github.com/ros-visualization/rviz/issues/1249. The solution may be related to your locales.

If that's the underlying issue, modifying the following environment variable will fix it for you:

export LC_NUMERIC="en_US.UTF-8".


Originally posted by dhood with karma: 621 on 2018-07-09

This answer was ACCEPTED on the original site

Post score: 6


Original comments

Comment by tik0 on 2018-08-28:
Setting this variable solved the issue indeed, thanks.

Comment by girayuzun on 2019-10-25:
that worked, thx If you want to make it in system;

echo 'LC_NUMERIC="en_US.UTF-8"' | sudo tee -a /etc/default/locale

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.