0
$\begingroup$

Rosanswers logo

Hello I'm a beginner on the ROS and linux world

I'm using a rplidar to get the laser map, however after the installation instruction from ROS kinetic tutorial I'm getting an error when after writing the command

roslaunch rplidar_ros view_rplidar.lanuch 

it gives me this error

Error,cannot bind to the specfifed serial port/dev/ttyUSB0

Then, I thought I had to download the driver which the SDK zip file from the rplidar website After that, when I go to my downloads directory

cd downloads ls

it show that I have the zip file

rplidar_sdk_v1.5.7.zip

and now I'm stuck, I don't how to unzip this file

I have tried this but it did not work

unzip"rplidar_sdk_v1.5.7.zip"

Also, I tried to look online for the port issue, but did not found a solution I tried the

ultra_simple /dev/ttyUSB0 

and also

chmod /dev/ttyUSB0

but none of them work

Sorry for the bad explanation but I'm kinda lost

Thank you

UPDATE :

After using ls /dev when the lidar is connected , here is what i get

hamzh@hamzh-VirtualBox:~$ ls /dev/
autofs           loop4               stderr  tty35  tty8       ttyS8
block            loop5               stdin   tty36  tty9       ttyS9
bsg              loop6               stdout  tty37  ttyprintk  uhid
btrfs-control    loop7               tty     tty38  ttyS0      uinput
bus              loop-control        tty0    tty39  ttyS1      urandom
cdrom            mapper              tty1    tty4   ttyS10     userio
char             mcelog              tty10   tty40  ttyS11     vboxguest
console          mem                 tty11   tty41  ttyS12     vboxuser
core             memory_bandwidth    tty12   tty42  ttyS13     vcs
cpu_dma_latency  mqueue              tty13   tty43  ttyS14     vcs1
cuse             net                 tty14   tty44  ttyS15     vcs2
disk             network_latency     tty15   tty45  ttyS16     vcs3
dri              network_throughput  tty16   tty46  ttyS17     vcs4
dvd              null                tty17   tty47  ttyS18     vcs5
ecryptfs         port                tty18   tty48  ttyS19     vcs6
fb0              ppp                 tty19   tty49  ttyS2      vcs7
fd               psaux               tty2    tty5   ttyS20     vcsa
full             ptmx                tty20   tty50  ttyS21     vcsa1
fuse             pts                 tty21   tty51  ttyS22     vcsa2
hidraw0          random              tty22   tty52  ttyS23     vcsa3
hpet             rfkill              tty23   tty53  ttyS24     vcsa4
hugepages        rtc                 tty24   tty54  ttyS25     vcsa5
hwrng            rtc0                tty25   tty55  ttyS26     vcsa6
i2c-0            sda                 tty26   tty56  ttyS27     vcsa7
initctl          sda1                tty27   tty57  ttyS28     vfio
input            sda2                tty28   tty58  ttyS29     vga_arbiter
kmsg             sda5                tty29   tty59  ttyS3      vhci
lightnvm         sg0                 tty3    tty6   ttyS30     vhost-net
log              sg1                 tty30   tty60  ttyS31     vhost-vsock
loop0            shm                 tty31   tty61  ttyS4      zero
loop1            snapshot            tty32   tty62  ttyS5
loop2            snd                 tty33   tty63  ttyS6
loop3            sr0                 tty34   tty7   ttyS7

When the lidar is not connected, here is what I get

autofs           full       loop5               pts       stdout  tty22  tty38  tty53      ttyS1   ttyS25   userio     vcsa6
block            fuse       loop6               random    tty     tty23  tty39  tty54      ttyS10  ttyS26   vboxguest  vcsa7
bsg              hidraw0    loop7               rfkill    tty0    tty24  tty4   tty55      ttyS11  ttyS27   vboxuser   vfio
btrfs-control    hpet       loop-control        rtc       tty1    tty25  tty40  tty56      ttyS12  ttyS28   vcs        vga_arbiter
bus              hugepages  mapper              rtc0      tty10   tty26  tty41  tty57      ttyS13  ttyS29   vcs1       vhci
cdrom            hwrng      mcelog              sda       tty11   tty27  tty42  tty58      ttyS14  ttyS3    vcs2       vhost-net
char             i2c-0      mem                 sda1      tty12   tty28  tty43  tty59      ttyS15  ttyS30   vcs3       vhost-vsock
console          initctl    memory_bandwidth    sda2      tty13   tty29  tty44  tty6       ttyS16  ttyS31   vcs4       zero
core             input      mqueue              sda5      tty14   tty3   tty45  tty60      ttyS17  ttyS4    vcs5
cpu_dma_latency  kmsg       net                 sg0       tty15   tty30  tty46  tty61      ttyS18  ttyS5    vcs6
cuse             lightnvm   network_latency     sg1       tty16   tty31  tty47  tty62      ttyS19  ttyS6    vcs7
disk             log        network_throughput  shm       tty17   tty32  tty48  tty63      ttyS2   ttyS7    vcsa
dri              loop0      null                snapshot  tty18   tty33  tty49  tty7       ttyS20  ttyS8    vcsa1
dvd              loop1      port                snd       tty19   tty34  tty5   tty8       ttyS21  ttyS9    vcsa2
ecryptfs         loop2      ppp                 sr0       tty2    tty35  tty50  tty9       ttyS22  uhid     vcsa3
fb0              loop3      psaux               stderr    tty20   tty36  tty51  ttyprintk  ttyS23  uinput   vcsa4
fd               loop4      ptmx                stdin     tty21   tty37  tty52  ttyS0      ttyS24  urandom  vcsa5

Originally posted by [email protected] on ROS Answers with karma: 35 on 2018-07-03

Post score: 1


Original comments

Comment by Delb on 2018-07-03:
Have you checked that the lidar is indeed connected to /dev/ttyUSB0 ?

Comment by [email protected] on 2018-07-03:
How do I do that ? I checked ls /dev

and ttyUSB0 is not on the list

Comment by Delb on 2018-07-03:
Yes ls /dev/ is how you do it and if you don't have ttyUSB0 in the list when your Lidar is connected then the issue is normal. Have you another ttyUSB in the list ? If so then change within the launch file ttyUSB0 to your ttyUSB.

Comment by Delb on 2018-07-03:
If you have mutliples ttyUSB then check ls /dev/ with the lidar deconnected, then connected to see which one is missing between the two tests

Comment by [email protected] on 2018-07-03:
I don't have any ttyUSB when I check ls /dev/

Comment by Delb on 2018-07-03:
With your Lidar connected ?

Comment by [email protected] on 2018-07-03:
Yes, I'm not sure if I need to unzip the drive ?

Comment by Delb on 2018-07-03:
Normally no but it's weird that you don't have any ttyUSB, can you edit your question and post the result of ls /dev/ when the lidar is connected and then deconnected ?

Comment by [email protected] on 2018-07-03:
I updated the question, sorry if is not clear and thank you for your help Do you think , I could be using a charge only cable ??

Comment by Delb on 2018-07-03:
Maybe try using the cable provided with the lidar (if you could edit again your question to give the output of ls /dev/input when the lidar is connected and deconnected it would be clearer, also using the preformatted text button (CTRL-K) it's clearer too)

Comment by [email protected] on 2018-07-03:
Here is what I get with the ls/dev/input when lidar is connected

by-id by-path event0 event1 event2 event3 event4 event5 event6 js0 js1 mice mouse0 mouse1

and I got the exact thing when the lidar is not connected

Comment by Delb on 2018-07-03:
That's not normal, have you changed the cable ?

Comment by [email protected] on 2018-07-03:
Yes I did, nothing has changed

Comment by Delb on 2018-07-03:
You should definitly have some changes when connecting your lidar, have you tried with the cable provided with your lidar ?

Comment by [email protected] on 2018-07-03:
There was no USB cable provided with the lidar

Comment by Delb on 2018-07-03:
Have you seen #q199561 ?

Comment by [email protected] on 2018-07-03:
Yes, I saw before but It did not help

Comment by Delb on 2018-07-04:
Have you tried the different solutions of the answers ? The issue is due to your lidar not detected by your computer but I don't see why. For your previous question about unzipping the file run unzip file.zip -d destination_folder (if it doesn't work run sudo apt-get install unzip)

Comment by Delb on 2018-07-04:
Maybe installing the SDK will help you to solve the issue

Comment by ahendrix on 2018-07-09:
Based on your hostname, it looks like you're running ROS inside a virtual machine. Have you correctly configured your virtual machine software to pass the Lidar's USB device to your Ubuntu VM?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I had the same error. For me, changing the USB wire worked. Yep, it was that simple for me


Originally posted by parzival with karma: 463 on 2019-07-16

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.