I have purchased the undermentioned robot chassis with DC motors supported with plastic gears from a local store. There is a 3A battery holder and when I connect robot to that and put it on the ground both the motors working fine and smooth. But when I connect the L298N motor controller which was made by myself and tested with proteus, only one motor is working. When I switch the wires of both motors, still the motor which worked before is working and the other motor never runs unless I manually give a little rotation to the wheel.

I use a PIC18F4431 to control the motor controller and tried USB power and a 5V regulator created by myself and the result is the same in both occasions. What could be the issue here? If I tried oiling the malfunctioning motor will it work? I heard one of my friends having the same issue, one motor is not working. But both motors work with just two pen torch batteries and can't think of a valid reason that the motor is faulty. May be my motor controller? But when I swap the wires from faulty to the working one, the working one still works as I've mentioned above.

Robot car chassis

enter image description hereenter image description here

  • $\begingroup$ It's possible the power supply (battery) just can't deliver enought current or voltage to run both motors at once. If you're just using 3 AA cells, you might get better results with more. Alternatively, if the wires from the battery, through the controller to the motors are very thin, this may restrict the current. $\endgroup$
    – Andy
    Dec 18, 2015 at 10:54
  • $\begingroup$ The motors work fine when connected to the stock motor controller but don't work when connected to your motor controller. Is this your problem? I would say that there's some mistake with your motor controller (and/or the batteries are low or dead as @Andy mentions). Can you post schematics for how you have everything setup? $\endgroup$
    – Chuck
    Dec 18, 2015 at 16:13
  • $\begingroup$ @Chuck No Chuck when I tried connecting the motors directly to the battery pack which is in my case two 3AA batteries, both motors work fine. But when I connect them to the motor controller and supply USB power, only one motor works. I have edited my post by adding schematics. $\endgroup$
    – Padmal
    Dec 19, 2015 at 2:18
  • $\begingroup$ @Andy But one motor is working and when I supply from 2 x 3AA batteries, both the motors work fine. But USB giving more current than those batteries right? $\endgroup$
    – Padmal
    Dec 19, 2015 at 2:20
  • 1
    $\begingroup$ continuing from @jwpat7 ; may you have hit the torque limit of the motors by giving less than required current to them? and maybe one of the motors is just a little bit less resisting the motion? $\endgroup$ Dec 19, 2015 at 8:03

1 Answer 1


Sounds like a load balancing problem in combination with a current issue. Do you have another L298N to try? Make sure the IC isn't defective, or have you checked the current draw at each motor. Do these motors have a capacitor installed across the leads on each motor? I doubt you hit the torque limit of the motors, as it appears that they came in a kit and were probably selected for the kit by the manufacturer because of their specs. It seems like You're not getting enough current to get past starting torque, a capacitor on each motor will help with the initial current draw.

How are you powering the USB? Is it from a laptop? Most USB ports on laptops put out pretty low current to save on battery. Try a powered USB hub.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.