0
$\begingroup$

Rosanswers logo

I would like to deploy a custom package and am having trouble getting it to work for all users on the machine. Currently I have my targets installable using CMake's install() and things are working fine for a single user (i.e., I install to some install space and then source the resulting setup.bash file).

My problem is when I try to move my install space somewhere for all users to access. Currently I am trying something to the effect of /usr/local/ros/kinetic/. If I set my install space as such I get write permission errors; catkin build with sudo seems wrong (environment setup issues); and installing locally and then copying/moving the resulting folder results in sourcing the resulting setup.bash having no effect.

I am using catkin-tools on Kinetic. Any advice would be greatly appreciated at this point.

-Brett


Originally posted by BrettHemes on ROS Answers with karma: 525 on 2018-04-25

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

If you're having trouble with write permissions using sudo. I'd recommend changing the permissions temporarily for the install destination to allow user write permissions. And then turn that off again after you've completed the installation.


Originally posted by tfoote with karma: 58457 on 2018-04-25

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by gvdhoorn on 2018-04-26:
This is indeed an acceptable work-around.

@BrettHemes: I've used either sudo -E catkin_make install in the past (as catkin_make separates install phase from configure & build), or sudo -E catkin build .. as that should keep env vars around.

Comment by BrettHemes on 2018-04-26:
"-E The -E (preserve environment) option indicates to the security policy that the user wishes to preserve their existing environment variables."

Nice!, I will try this out. Thanks!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.