0
$\begingroup$

Rosanswers logo

Hi there , I trying to install hector slam package on raspberry pi3 (ubuntu mate)

I installed hector slam package through git clone command

But the error generated when I compiled it. (scanning dependencies of target)

the phenomenon is that compiling speed was very slow (almost stop)

How can i solve this problem?? I have to implement hector mapping on raspberry pi3. please answers..

Someone told me to install through apt-get (It does not require compilation <- right?)

I'm sorry my grammer T.T


Originally posted by DongHyeong Kang on ROS Answers with karma: 13 on 2018-04-24

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Ubuntu Mate has a lot of overhead. Try the Raspberry Pi distribution from downloads.ubiquityrobotics.com. If you have trouble compiling with a default catkin_make, use the -j1 parameter, it takes longer but may work if the default -j4 fails.


Originally posted by DrBot with karma: 147 on 2018-07-03

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by v.leto on 2019-11-02:
HOw can I change -j4 to -j1?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.