0
$\begingroup$

Rosanswers logo

Hi, I am trying to control gazebo simulated arm mounted on mobile base through moveit. When I try to execute the trajectories after setting starting and goal positions, I am getting "Maybe failed to update robot state, time diff: 0,822s"in my terminal. When I remove robot_state_publisher from my launch file trajectories are being executed. But i need tf tree to visualize octomap. my launch files:

<launch>

    <arg name="paused" default="false" />
    <arg name="use_sim_time" default="true" />
    <arg name="gui" default="true" />
    <arg name="headless" default="false" />
    <arg name="debug" default="false" />
    <arg name="model" default="$(find kate_jaco)/urdf/kate_jaco.xacro"/>
    <arg name="rvizconfig" default="$(find kate_jaco)/rviz/urdf.rviz" />

<!-- We resume the logic in empty_world.launch, changing only the name of 
        the world to be launched -->
    <include file="$(find gazebo_ros)/launch/empty_world.launch">
        <arg name="world_name" value="/home/iki/iki.world"/>
        
        <arg name="debug" value="$(arg debug)" />
        <arg name="gui" value="$(arg gui)" />
        <arg name="paused" value="$(arg paused)" />
        <arg name="use_sim_time" value="$(arg use_sim_time)" />
        <arg name="headless" value="$(arg headless)" />
        
    </include>

<!-- Load the URDF into the ROS Parameter Server -->
    <param name="robot_description" command="$(find xacro)/xacro.py '$(find kate_jaco)/urdf/kate_jaco.xacro'"/>
    <param name="use_gui" value="$(arg gui)"/>

<node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher" />

<node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher"
    respawn="false" output="screen">
      
  </node>
    
<rosparam file="$(find kate_jaco)/config/kate_jaco.yaml" command="load"/>
<rosparam file="$(find kate_jaco)/config/jaco.yaml" command="load"/>
    <node name="controller_spawner" pkg="controller_manager" type="spawner" respawn="false"
    output="screen" ns="/kate_jaco"  args="joint1_position_controller joint2_position_controller joint_state_controller jaco2_controller jaco2_gripper_controller  ">
        
        </node>
    <!-- Run a python script to the send a service call to gazebo_ros to spawn 
        a URDF robot -->
    <node name="urdf_spawner" pkg="gazebo_ros" type="spawn_model"
        respawn="false" output="screen" args="-urdf -model kate_jaco -param robot_description"/>

</launch>

my moveit launch file:

<launch>

  <rosparam command="load" file="$(find kate_jaco_moveit)/config/joint_names.yaml"/>

  <include file="$(find kate_jaco_moveit)/launch/planning_context.launch" >
    <arg name="load_robot_description" value="true" />
  </include>

  <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher">
    <param name="/use_gui" value="false"/>
    <rosparam param="/source_list">[/kate_jaco/joint_states]</rosparam>
  </node>

  <include file="$(find kate_jaco_moveit)/launch/move_group.launch">
    <arg name="publish_monitored_planning_scene" value="true" />
  </include>

  <include file="$(find kate_jaco_moveit)/launch/moveit_rviz.launch">
    <arg name="config" value="true"/>
  </include>

</launch>

PS: I strongly feel, there is something wrong with the robot state publisher and tf_static topic published by it.


Originally posted by ARB on ROS Answers with karma: 51 on 2018-03-26

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Was able to solve this.....there was problem with octomap update..due to heavy point cloud data,move group was unable to update robot state quickly..just reduce the rate at which point cloud is being published.


Originally posted by ARB with karma: 51 on 2018-03-26

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.