0
$\begingroup$

Rosanswers logo

Hello, I followed realsense tutorial from the link. In the end when I ran the camera node it cannot find the camera. I did not install any other realsense software prior to this tutorial. My error log is below. Basically it says no camera is detected, even though my camera is attaced via USB3.0 port.

My camera is Creative BlasterX Senz3D Appreciate your help.

robolab3@robolab3-Inspiron-7566:~$ roslaunch realsense_camera sr300_nodelet_default.launch ... logging to /home/robolab3/.ros/log/853b5580-3031-11e8-9952-701ce722ed90/roslaunch-robolab3-Inspiron-7566-3853.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://robolab3-Inspiron-7566:41951/

SUMMARY

PARAMETERS

  • /camera/driver/base_frame_id: camera_link
  • /camera/driver/camera_type: SR300
  • /camera/driver/color_fps: 30
  • /camera/driver/color_frame_id: camera_rgb_frame
  • /camera/driver/color_optical_frame_id: camera_rgb_optica...
  • /camera/driver/depth_frame_id: camera_depth_frame
  • /camera/driver/depth_height: 480
  • /camera/driver/depth_optical_frame_id: camera_depth_opti...
  • /camera/driver/depth_width: 640
  • /camera/driver/fisheye_frame_id: camera_fisheye_frame
  • /camera/driver/fisheye_optical_frame_id: camera_fisheye_op...
  • /camera/driver/imu_frame_id: camera_imu_frame
  • /camera/driver/imu_optical_frame_id: camera_imu_optica...
  • /camera/driver/ir2_frame_id: camera_ir2_frame
  • /camera/driver/ir2_optical_frame_id: camera_ir2_optica...
  • /camera/driver/ir_frame_id: camera_ir_frame
  • /camera/driver/ir_optical_frame_id: camera_ir_optical...
  • /camera/driver/mode: manual
  • /camera/driver/serial_no:
  • /camera/driver/usb_port_id:
  • /rosdistro: kinetic
  • /rosversion: 1.12.13

NODES /camera/ driver (nodelet/nodelet) nodelet_manager (nodelet/nodelet)

auto-starting new master process[master]: started with pid [3864] ROS_MASTER_URI=http://localhost:11311

setting /run_id to 853b5580-3031-11e8-9952-701ce722ed90 process[rosout-1]: started with pid [3877] started core service [/rosout] process[camera/nodelet_manager-2]: started with pid [3880] process[camera/driver-3]: started with pid [3881] [ INFO] [1521984989.992136254]: Initializing nodelet with 8 worker threads. [ERROR] [1521984991.211543763]: /camera/driver - No cameras detected! [ERROR] [1521984991.211636793]: /camera/driver - Error calling rs_create_context ( api_version:11100 ): libusb_open(...) returned LIBUSB_ERROR_ACCESS

[FATAL] [1521984991.335266767]: Failed to load nodelet '/camera/driverof typerealsense_camera/SR300Nodeletto managernodelet_manager' [camera/driver-3] process has died [pid 3881, exit code 255, cmd /opt/ros/kinetic/lib/nodelet/nodelet load realsense_camera/SR300Nodelet nodelet_manager depth:=depth color:=color ir:=ir ir2:=ir2 fisheye:=fisheye imu:=imu __name:=driver __log:=/home/robolab3/.ros/log/853b5580-3031-11e8-9952-701ce722ed90/camera-driver-3.log]. log file: /home/robolab3/.ros/log/853b5580-3031-11e8-9952-701ce722ed90/camera-driver-3*.log


Originally posted by tolga-uni-lu on ROS Answers with karma: 33 on 2018-03-25

Post score: 0


Original comments

Comment by Maarten on 2018-03-25:
The LIBUSB_ERROR_ACCESS error message on libusb_open makes me think the driver found the device, but the user running ROS has no access to it. Try adding the user to the plugdev group, or modify/add udev rules to give the user access to this device (depending on your security requirements).

Comment by tolga-uni-lu on 2018-03-26:
Try adding the user to the plugdev group: How can I do it?

Comment by dljubic on 2018-03-26:
Adding a user to the plugdev group is the 3. option in my answer.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hello tolga-uni-lu,
unfortunately, it is not easy to debug this issue. I have also experienced some difficulties while trying to enable RealSense products for the first time.

There are few pieces of advice that may help you...

  1. unplug the camera and plug it back again. Try it a couple of times while changing USB ports (it has to be USB 3.0). Seems stupid, but it helps sometimes.
  2. Which kernel are you using? I was having difficulties with the newest version (4.13) and everything worked fine on 4.8 and 4.4. To be able to find out which kernel you are using, you could type uname -r in terminal. If your kernel is higher version than 4.8, try choosing another when booting. In grub menu, you can choose Advanced options and choose which kernel version you like.
  3. sudo adduser "username" plugdev - I found this here and the same problem is also mentioned here

However, if you are using Creative BlasterX Senz3D, which should be an SR300 camera. You could try the newer version of the software. If you take a look at RealSense github, it says:

Intel® RealSense™ SDK 2.0 is a cross-platform library for Intel® RealSense™ depth cameras (D400 series and the SR300). For other Intel® RealSense™ devices (F200, R200, L200 and ZR300), please refer to the latest legacy release.

Therefore, if I were you, I would try advice 1) and 2). If it does not help, I would follow the instructions here and install the newer version of the software. You just have to have in mind that, if you are using librealsense2, you should use this ROS package.

There are many discussions on the realsense forum and their github issues. If the problem persists, you can always post questions there since maybe more RealSense users are watching.

However, if you have any further questions, feel free to ask here. :)


Originally posted by dljubic with karma: 516 on 2018-03-25

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by tolga-uni-lu on 2018-03-26:
Hi, Hi I followed these instructinos after a clean installation of Ubuntu. (Yes I reinstalled ROS-Openpose-CUDA etc again to fix). I run on 4.13. Now there is no error in dmesg and camera runs. But I cant get any vision.

Comment by tolga-uni-lu on 2018-03-26:
I tried to run rviz to get some vision but it is all black. Do you have any idea about that? I am not sure if this is the continuation of previous bug or a new issue.

Comment by dljubic on 2018-03-26:
It would be helpful to see rostopic list and look if the camera topics appear on that list. If it does, you can then do rostopic echo <camera topic> and see if there is any data appearing in the messages.

Comment by tolga-uni-lu on 2018-03-26:
robolab3@robolab3-Inspiron-7566:~/catkin_ws$ rostopic list /camera/color/camera_info /camera/color/image_raw /camera/color/image_raw/compressed /camera/color/image_raw/compressed/parameter_descriptions

.

.

.

And it goes on until tf_static

Comment by dljubic on 2018-03-26:
It seems that there is an image topic available. Try running rosrun rqt_image_view rqt_image_view and choose /camera/color/image_raw.

Comment by tolga-uni-lu on 2018-03-28:
Thank you!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.