0
$\begingroup$

Rosanswers logo

Hello, I am working with Ubuntu 16.04 and ros kinetic. I am trying to experiment with Ros QT for designing an interface for my project. I haven't been able to get the rqt command to display the plugins that I have installed.

I am a ROS newbie, so it is plausible that I made a mistake with how I installed rqt, but what I did was that I started with a clean install of Ubuntu 16.04, I followed the instructions listed here: http://wiki.ros.org/kinetic/Installation/Ubuntu and here http://wiki.ros.org/ROS/Tutorials/InstallingandConfiguringROSEnvironment to verify ROS was installed correctly.

I then ran the commands

$ sudo apt-get install ros-kinetic-rqt ros-kinetic-rqt-common-plugins

$ sudo apt-get update

$ sudo apt-get dist-upgrade

as instructed here http://wiki.ros.org/rqt/UserGuide/Install/Groovy

When I run the command

$rqt

I only get a blank window with no text.

I tried to verify that I had plugins installed by running

$ rqt --list-plugins

and I do get a populated list, and I can run the 'rqt_image_view' plugin directly from the command line.

My question is why do I not see any options to run plugins from the rqt window? Any insight or advice would be greatly appreciated.


Originally posted by Coppermind on ROS Answers with karma: 30 on 2018-03-24

Post score: 1

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

On my 16.04 I see menus on the Ubuntu's top panel, not on rqt's window (I think the default appearance changed sometimes between 14.04 and 16.04?).

Seems like you can change that setting on Ubuntu's level, see this example.


Originally posted by 130s with karma: 10937 on 2018-03-24

This answer was ACCEPTED on the original site

Post score: 3


Original comments

Comment by gvdhoorn on 2018-03-24:
This could very well be the cause here.

Comment by Coppermind on 2018-03-24:
This did turn out to be the issue, thank you for your help.

Comment by ishwar on 2019-11-17:
This worked. Such a simple issue. Thanks a lot!!

Comment by Kansai on 2021-01-06:
what? I don"t understand what this means

$\endgroup$
0
$\begingroup$

Rosanswers logo

Try to run rqt with the --force-discover option. Some times a cache needs to be updated.

Related question: #q166851.


Originally posted by gvdhoorn with karma: 86574 on 2018-03-24

This answer was NOT ACCEPTED on the original site

Post score: 4

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.