0
$\begingroup$

Rosanswers logo

Hello,

I am using kinect sensor for object recognition. Followed the below steps to see kinect sensor view in RViz.

  1. Connected the kinect sensor to my desktop.
  2. Ran "roslaunch openni_launch openni.launch"
  3. Ran "rosrun rviz rviz" and Set the Fixed Frame (in Global Options, Displays window) to /camera_depth_optical_frame. Added a PointCloud2 display and set the topic to /camera/depth/points.
  4. Ran "rosrun rqt_reconfigure rqt_reconfigure" and then selected /camera/driver from the drop-down menu and enabled the depth_registration checkbox.

The camera view in RViz is not proper according to the plane. It is showing upwards. Please let me know, how to change the settings to make the view proper. The expected view should be link text

Platfrom: Ubuntu 16.04, ROS Kinetic


Originally posted by Nitin on ROS Answers with karma: 36 on 2018-03-19

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

depth_optical_frame has z+ pointing forward (ie: into the world). As Rviz global frame has z+ upwards (ie: out of the xy plane), your pointcloud is projected "onto the ceiling". You'll have to publish a transform between your Fixed Frame and (most likely) the camera_link to change this.


Originally posted by gvdhoorn with karma: 86574 on 2018-03-19

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.