0
$\begingroup$

Rosanswers logo

after i install rtabmap from source when i try to run it i got this error: [ WARN] [1516726659.614500547]: /rtabmap/rtabmap: Did not receive data since 5 seconds! Make sure the input topics are published ("$ rostopic hz my_topic") and the timestamps in their header are set. If topics are coming from different computers, make sure the clocks of the computers are synchronized ("ntpdate"). If topics are not published at the same rate, you could increase "queue_size" parameter (current=10). /rtabmap/rtabmap subscribed to (approx sync): /rtabmap/odom, /camera/rgb/image_rect_color, /camera/depth_registered/sw_registered/image_rect_raw, /camera/rgb/camera_info

rostopic hz /rtabmap/odom: subscribed to [/rtabmap/odom] no new message rostopic hz /camera/rgb/image_rect_color subscribed to [/camera/rgb/image_rect_color] no new messages rostopic hz /camera/depth/image_rect_color WARNING: topic [/camera/depth/image_rect_color] does not appear to be published yet

so what i can do to resole this issues


Originally posted by abdelkrim on ROS Answers with karma: 9 on 2018-01-23

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

With zed camera, the depth image topic would be something like this: /camera/depth/depth_registered. You may want to try Zed related instructions on this page.

cheers


Originally posted by matlabbe with karma: 6409 on 2018-01-23

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by abdelkrim on 2018-01-24:
@matlabbe i tried it all but i get the same issue

Comment by matlabbe on 2018-01-24:
Try "$ rostopic hz my/topic" on needed topics to know if they are actually published. You can also start only the zed, then do "$ rostopic list" to list all available topics and copy/paste them in your question.

Comment by abdelkrim on 2018-01-24:
When i run only zed i get all topic available

Comment by matlabbe on 2018-01-24:
... and are they published? (use rostopic hz)

Comment by abdelkrim on 2018-01-26:
@matlabbe i can see the image when i run rqt_image_view

but no data published in rostopic hz my/topic

Comment by abdelkrim on 2018-01-26:
the issue resolved just in rtabmapviz but not in rviz

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.