0
$\begingroup$

Rosanswers logo

Hey :-)

System: Ubuntu 16.04

ROS: Lunar (tried Kinetic before) Desktop Full

rtabmap version : 0.13.2

My approach ist to use the rtabmap feature in cooperation with Tango ROS Streamer which is already running fine.

I followed the instructions on this tutorial :

http://wiki.ros.org/rtabmap_ros/Tutorials/Tango%20ROS%20Streamer

At step 6 it fails at this command

rosrun rtabmap_ros pointcloud_to_depthimage cloud:=/tango/point_cloud camera_info:=/tango/camera/color_1/camera_info _fixed_frame_id:=start_of_service _decimation:=8 _fill_holes_size:=5

with the error:

[rosrun] Couldn't find executable named pointcloud_to_depthimage below /opt/ros/lunar/share/rtabmap_ros

I already installed rtabmap via:

sudo apt install ros-lunar-rtabmap-ros

What could go wrong ? -_-

best regards and many thanks in advance for any help

Mark


Originally posted by Markovicho on ROS Answers with karma: 15 on 2018-01-19

Post score: 0


Original comments

Comment by PeteBlackerThe3rd on 2018-01-19:
Did you get any errors when you installed rtabmap? Have your sourced the setup.bash file for ros?

Comment by Markovicho on 2018-01-19:
No errors on the installation... setup.bash is attached to my ~/.bashrc as well running "rosdep init && rosdep update"

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I have already seen the same error, but forgot to write an error report. pointcloud_to_depthimage seems not to be included in the deb package or is not installed. I've compiled rtabmap from source.


Originally posted by ChriMo with karma: 476 on 2018-01-22

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Markovicho on 2018-01-22:
Thanks a lot !!!

This worked:

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.