0
$\begingroup$

Rosanswers logo

hi, i used this file link text for create map and localization by stereo images. but when i used parameter (rviz:=true), rtabmapviz and rviz simultaneous run and this error is created: [pcl::VoxelGrid::applyFilter] Leaf size is too small for the input dataset. Integer indices would overflow.

please help me


Originally posted by zahra.kh on ROS Answers with karma: 21 on 2018-01-16

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The warning was coming from rtabmap_ros/points_xyzrgb nodelet, caused by the voxel_size parameter which was set too small for the stereo point clouds. This is fixed in this commit where voxel_size is now disabled by default.

cheers


Originally posted by matlabbe with karma: 6409 on 2018-01-17

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by zahra.kh on 2018-01-18:
how can i solved this problem? Should I update rtabmap_ros package?

Comment by matlabbe on 2018-01-18:
You can manually make the change in your installed rtabmap.launch, or copy rtabmap.launch to another location and modify it. No rebuild from source is required as it is a change in a launch file. You can also not subscribe to voxel_cloud in RVIZ, then the warning will disappear.

Comment by zahra.kh on 2018-01-18:
thanks, matlabbe

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.