Rosanswers logo


Edit: See self- reply for semi-successful update, though I still cannot get a pointcloud topic publishing (just depthcloud)

I have been trying for 8.5 hours today to try and get my kinect v1 to output a depth pointcloud to RVIZ as per the ROS tutorial. I found the ROS kinect setup instructions tough to follow, so initially I made the install by following this reddit guide.

Thereafter I could get the kinect to work by cd'ing to the openni directory it created, and using the samples to view image and depth data. However once out of the directory and entering roslaunch openni_launch openni.launch, though it would run openni with no error messages, no topics would publish, except static_tf, rosout and rosout_agg). I was unable to bring up the depth camera points topic in rviz and the topics selector under PointCloud2, when added to rviz, was empty. When trying to run rosrun image_view image_view image:=/camera/rgb/image_color, a window would appear and immediately crash.

Then I tried using freenect1 and got the additional topics of: /camera/depth_rectify_depth/parameter_descriptions and /camera/depth_rectify_depth/parameter_updates by using variations on the command roslaunch freenect_launch freenect.launch.

rosrun image_view image_view image:=/camera/rgb/image_color would still crash (consistent issue across all attempts).

I tried editing the openni launch file to add in the device ID in place of the default '#1', no dice.

Eventually I tore everything out and went back to try and work through the ROS Wiki instructions. It says something about using rgbd.launch as of hydro, but the instructions still appear to require the installation of openni nonetheless. Eventually I tried to reinstall following this page http://wiki.ros.org/openni_camera but despite following the line of advice that says

... after you have installed the OpenNI, and be ready to clone the git files for SensorKinect,DO NOT change directory!Otherwise you cannot generate the Redist directory for installation of SensorKinect

The Redist folder still would not generate. Its not clear which folder you should actually be in and I tried a fair few, to no result.

I also tried good old sudo apt-get install ros-kinetic-openni-camera ros-kinetic-openni-launch. Nada.

So after a day of trying to make it work and scouring google, I am completely stumped. No error messages, but no topics either :(

Does the Kinect V1 actually work still with Ubuntu 16.04 and Kinetic? Or has something changed? Is there a current up to date ROS approved one-pager with the process detailed?

Edit: Update:

Intermittently, I can get roslaunch freenect_launch freenect.launch device_id:={serial number} to give me more topics, though this does not include point cloud (camera/depth/points):


I have been able to bring up a depthcloud, as opposed to a pointcloud, the latter of which is still blank when adding a pointcloud2 object as per the original ROS tutorial. Is there a difference between pointcloud and depth cloud, and should a pointcloud be available in the topics list?

I note that none of the freenect or openni launch files contain any reference to "points", has this functionality been removed? I have also looked in freenect-registered-xyzrgb and freenect-xyz, which the documentation says should give pointclouds.

The intermittent nature of it running all topics also seems to be perplexing, which may be down to a background process needing to stop. killall XsSensorServer does not help.

Originally posted by Wireline on ROS Answers with karma: 48 on 2018-01-09

Post score: 0

Original comments

Comment by gvdhoorn on 2018-01-10:
Please do not use answers to provide updates. Only post one if/when you're really answering your own question.

Seeing questions with answers tends to discourage other members from posting, so it's best not to do that.


1 Answer 1


Rosanswers logo

Right I found the problem. I recently installed Jetpack 3.1 on an nvidia TX2, which somehow affects the apt-get update command on the host machine and the TX2. You cannot update anything, and so my ROS packages were out of date despite believing I had updated them (that'll teach me to ignore update terminal output).

Now I have run the update, everything works fine. For a workaround on the TX2 issue, see this nvidia forum post https://devtalk.nvidia.com/default/topic/1002140/jetson-tx2/apt-get-update-errors/1 . There may be further topics on it, so search around. I dont know if its fixed in the latest jetpack versions, so one to be aware of if you just got a TX2

Originally posted by Wireline with karma: 48 on 2018-01-13

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by KSWang on 2018-08-08:
I get similar problem too. Can you describe more detail how you update TX2, thanks a lot


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.