0
$\begingroup$

i am using this sensor to make self balancing robot.At first i have soldered the header(only to vcc,gnd,scl,sda ) on the imu borad at the opposite side where there is no component mounted.then connecting it to arduino uno r3(vcc to vcc 3.3v/5v,gnd to 1 of 3 gnd,scl to scl and sda to sda(first time at those next to AREF, second time A5,A4) ) i uploaded the sketch https://github.com/adafruit/Adafruit_ADXL345/blob/master/examples/sensortest/sensortest.pde then when i opened the serial monitor i got

Accelerometer Test

FF Ooops, no ADXL345 detected ... Check your wiring!

i thought may be i have soldered the header in wrong direction(as in picture and videos at internet,they are so) so i desolder(with solder iron,no other technique) the header,but there were still some solder around the hole which i could not remove.then while checking the continuity between pins with multimiter(in resistance mode) i found the resistance to be 20k(scl-sda),220k(scl-gnd),220k(sda-gnd),between vcc and 3 other pins multimieter shows 1(range 2000k). then i soldered it on opposit side(this time where other components are mounted).the serial monitor still shows same output,and so does the muiltimeter.so where is the problem? is it with soldering ?do i need to disolder the header again and clean left out solder(with Chip Quik type desoldering technique ) on the opposite side(no component mounted)?is there any hope that i won't need to buy it again?

picture of opposite side where no component is mounted and this is after desoldering and resoldering

$\endgroup$
1
  • $\begingroup$ Have you got it working once without soldering, just with cabling it? $\endgroup$ – ott-- Apr 5 '16 at 17:18
1
$\begingroup$

I don't know the details of the ADXL345 or the MPU-9250, but I wouldn't expect a MPU-9250 to respond to the Arduino running a program for the ADXL345. So my first suggestion is to search for the right program for your board.

Secondly I think you are using I2C to connect to the board. The SCL and SDA lines need pull up resistors, so place a 4.7K resistor between SDA and VCC and another between SCL and VCC.

Both the chips you mentioned are 3.3V chips, the boards might handle 5V but you need to check the data sheets. If they can't hand 5V then you will need a logic level shifter.

You might have problems getting a good connection on the two holes, but that's only a problem if you need them and I don't think with I2C you will.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.