0
$\begingroup$

Rosanswers logo

Hi,all, we are using navfn in move_base to plan a global path for a robot. For now, the experiments are being done in a simulated environment by gazebo. However, we found that if the robot is close to a wall, if a goal is on the another side of the wall, the generated path from navfn often goes through the wall. Please see the below two images.

The first image shows the generated path when the inflation layer is canceled. The second image shows the generated path with a running inflation layer. Both of these two path go through the wall.

I have read a similiar question here. But the walls in the illustrated instance are intermittent(not constantly). On the contrary, as you can see from the below images, the walls are constantly(unintermittent).

Is this a bug of navfun? Looking forwards to any advices to improve navfn! Thanks!

image description

image description


Originally posted by scopus on ROS Answers with karma: 279 on 2017-10-25

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Try setting allow_unknown to false. http://wiki.ros.org/navfn#Parameters


Originally posted by David Lu with karma: 10932 on 2017-10-26

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by scopus on 2017-10-31:
Thank you very much! We checked the vaule of allow_unknow. It was alrealy "false". And in obstacle layer, the track_unknown_space was also set to be true as needed. The problem still exists.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.