0
$\begingroup$

Rosanswers logo

I just buy SparkFun 9DoF Razor IMU M0, https://www.sparkfun.com/products/14001 , want to install http://wiki.ros.org/razor_imu_9dof,but failed

problem is :in razor_imu_9dof tutorial,it's using old IMU , SparkFun 9DoF Razor IMU (SEN-10736) - Initial release, featuring an ATmega328, ADXL345 (accelerometer), ITG-3200 (gyroscope), and HMC5883L (magnetometer).

I buy the new one :SparkFun 9DoF Razor IMU M0 (SEN-14001)

what should I do in http://wiki.ros.org/razor_imu_9dof#Load_Firmware_into_Razor_Board ?

Firmware can not upload to IMU M0 .

Razor_AHRS.ino:

// HARDWARE OPTIONS

/*****************************************************************/

// Select your hardware here by uncommenting one line!

//#define HW__VERSION_CODE 10125 // SparkFun "9DOF Razor IMU" version "SEN-10125" (HMC5843 magnetometer)

//#define HW__VERSION_CODE 10736 // SparkFun "9DOF Razor IMU" version "SEN-10736" (HMC5883L magnetometer)

//#define HW__VERSION_CODE 10183 // SparkFun "9DOF Sensor Stick" version "SEN-10183" (HMC5843 magnetometer)

//#define HW__VERSION_CODE 10321 // SparkFun "9DOF Sensor Stick" version "SEN-10321" (HMC5843 magnetometer)

//#define HW__VERSION_CODE 10724 // SparkFun "9DOF Sensor Stick" version "SEN-10724" (HMC5883L magnetometer)


Originally posted by play4fun on ROS Answers with karma: 16 on 2017-10-20

Post score: 0

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

Hi There, I'm currently working through the same problem, trying to get the razor_imu_9dof ROS node to work with the new 14001 based sparkfun boards. I'm (hopefully) almost there, I've found the git repo below that does work with the new board. It outputs the linear and angular accelerations fine although as far as I can tell the orientation estimate is wrong, I'm getting incorrect values or NANs.

https://github.com/lebarsfa/razor-9dof-ahrs

Depending on your application this may solve your problem straight away, if you only need the acceleration values.


Originally posted by PeteBlackerThe3rd with karma: 9529 on 2017-11-29

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

According to this issue on the bug tracker for razor_imu_9dof, it looks like razor_imu_9dof doesn't support the newer boards, but it looks like there's another package or firmware that might.


Originally posted by ahendrix with karma: 47576 on 2017-10-21

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by play4fun on 2017-10-22:
Thanks,I have already try it ,still not working. don't know why.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.