0
$\begingroup$

Rosanswers logo

Hi, I am new here and I was trying to install ROS hydro on Ubuntu 12.04.05 LTS. I have followed the ROS wiki instructions but i got this error after:

sudo apt-get install ros-hydro-desktop-full

Ubuntu is on a virtual machine by Parallels Box on mac. I'd like to add that the same installation at the same version of ubuntu and ros was fine with typical linux installation (not with virtual machine). I hope someone can help me!

This is what I've got after sudo apt-get update

Hit http://security.ubuntu.com precise-security Release.gpg
Get:1 http://extras.ubuntu.com precise Release.gpg [72 B]                      
Hit http://security.ubuntu.com precise-security Release                        
Hit http://extras.ubuntu.com precise Release                                   
Hit http://us.archive.ubuntu.com precise Release.gpg                           
Hit http://us.archive.ubuntu.com precise-updates Release.gpg                   
Hit http://us.archive.ubuntu.com precise-backports Release.gpg                 
Hit http://security.ubuntu.com precise-security/main Sources                   
Hit http://extras.ubuntu.com precise/main Sources                              
Hit http://security.ubuntu.com precise-security/restricted Sources             
Hit http://security.ubuntu.com precise-security/universe Sources               
Hit http://security.ubuntu.com precise-security/multiverse Sources             
Hit http://security.ubuntu.com precise-security/main amd64 Packages            
Hit http://security.ubuntu.com precise-security/restricted amd64 Packages      
Hit http://security.ubuntu.com precise-security/universe amd64 Packages        
Hit http://security.ubuntu.com precise-security/multiverse amd64 Packages      
Hit http://security.ubuntu.com precise-security/main i386 Packages             
Hit http://security.ubuntu.com precise-security/restricted i386 Packages       
Hit http://security.ubuntu.com precise-security/universe i386 Packages         
Hit http://extras.ubuntu.com precise/main amd64 Packages                       
Hit http://extras.ubuntu.com precise/main i386 Packages                        
Ign http://extras.ubuntu.com precise/main TranslationIndex                     
Hit http://us.archive.ubuntu.com precise Release                               
Hit http://us.archive.ubuntu.com precise-updates Release                       
Hit http://security.ubuntu.com precise-security/multiverse i386 Packages       
Hit http://security.ubuntu.com precise-security/main TranslationIndex          
Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex    
Hit http://security.ubuntu.com precise-security/restricted TranslationIndex    
Hit http://security.ubuntu.com precise-security/universe TranslationIndex      
Hit http://security.ubuntu.com precise-security/main Translation-en            
Hit http://security.ubuntu.com precise-security/multiverse Translation-en      
Hit http://security.ubuntu.com precise-security/restricted Translation-en      
Hit http://us.archive.ubuntu.com precise-backports Release                     
Hit http://security.ubuntu.com precise-security/universe Translation-en        
Hit http://packages.ros.org trusty Release.gpg                                 
Hit http://us.archive.ubuntu.com precise/main Sources                 
Hit http://us.archive.ubuntu.com precise/restricted Sources           
Hit http://us.archive.ubuntu.com precise/universe Sources             
Hit http://us.archive.ubuntu.com precise/multiverse Sources           
Hit http://us.archive.ubuntu.com precise/main amd64 Packages          
Hit http://us.archive.ubuntu.com precise/restricted amd64 Packages    
Hit http://us.archive.ubuntu.com precise/universe amd64 Packages               
Hit http://us.archive.ubuntu.com precise/multiverse amd64 Packages             
Hit http://us.archive.ubuntu.com precise/main i386 Packages                    
Hit http://us.archive.ubuntu.com precise/restricted i386 Packages  
Hit http://us.archive.ubuntu.com precise/universe i386 Packages                
Hit http://us.archive.ubuntu.com precise/multiverse i386 Packages              
Hit http://us.archive.ubuntu.com precise/main TranslationIndex                 
Hit http://us.archive.ubuntu.com precise/multiverse TranslationIndex           
Hit http://us.archive.ubuntu.com precise/restricted TranslationIndex           
Hit http://us.archive.ubuntu.com precise/universe TranslationIndex             
Hit http://us.archive.ubuntu.com precise-updates/main Sources                  
Hit http://us.archive.ubuntu.com precise-updates/restricted Sources            
Hit http://us.archive.ubuntu.com precise-updates/universe Sources              
Hit http://us.archive.ubuntu.com precise-updates/multiverse Sources            
Hit http://packages.ros.org trusty Release                                     
Ign http://extras.ubuntu.com precise/main Translation-en_US                    
Hit http://us.archive.ubuntu.com precise-updates/main amd64 Packages
Hit http://us.archive.ubuntu.com precise-updates/restricted amd64 Packages
Hit http://us.archive.ubuntu.com precise-updates/universe amd64 Packages
Hit http://us.archive.ubuntu.com precise-updates/multiverse amd64 Packages
Hit http://us.archive.ubuntu.com precise-updates/main i386 Packages            
Hit http://us.archive.ubuntu.com precise-updates/restricted i386 Packages      
Hit http://us.archive.ubuntu.com precise-updates/universe i386 Packages        
Hit http://us.archive.ubuntu.com precise-updates/multiverse i386 Packages      
Hit http://us.archive.ubuntu.com precise-updates/main TranslationIndex         
Hit http://us.archive.ubuntu.com precise-updates/multiverse TranslationIndex   
Ign http://extras.ubuntu.com precise/main Translation-en                       
Hit http://packages.ros.org trusty/main amd64 Packages                         
Hit http://us.archive.ubuntu.com precise-updates/restricted TranslationIndex
Hit http://us.archive.ubuntu.com precise-updates/universe TranslationIndex
Hit http://us.archive.ubuntu.com precise-backports/main Sources
Hit http://us.archive.ubuntu.com precise-backports/restricted Sources
Hit http://us.archive.ubuntu.com precise-backports/universe Sources
Hit http://us.archive.ubuntu.com precise-backports/multiverse Sources
Hit http://us.archive.ubuntu.com precise-backports/main amd64 Packages
Hit http://us.archive.ubuntu.com precise-backports/restricted amd64 Packages
Hit http://us.archive.ubuntu.com precise-backports/universe amd64 Packages
Hit http://us.archive.ubuntu.com precise-backports/multiverse amd64 Packages
Hit http://us.archive.ubuntu.com precise-backports/main i386 Packages
Hit http://us.archive.ubuntu.com precise-backports/restricted i386 Packages
Hit http://us.archive.ubuntu.com precise-backports/universe i386 Packages
Hit http://us.archive.ubuntu.com precise-backports/multiverse i386 Packages
Hit http://us.archive.ubuntu.com precise-backports/main TranslationIndex
Hit http://us.archive.ubuntu.com precise-backports/multiverse TranslationIndex
Hit http://packages.ros.org trusty/main i386 Packages               
Ign http://packages.ros.org trusty/main TranslationIndex           
Hit http://us.archive.ubuntu.com precise-backports/restricted TranslationIndex
Hit http://us.archive.ubuntu.com precise-backports/universe TranslationIndex
Hit http://us.archive.ubuntu.com precise/main Translation-en
Hit http://us.archive.ubuntu.com precise/multiverse Translation-en
Hit http://us.archive.ubuntu.com precise/restricted Translation-en 
Hit http://us.archive.ubuntu.com precise/universe Translation-en   
Hit http://us.archive.ubuntu.com precise-updates/main Translation-en
Hit http://us.archive.ubuntu.com precise-updates/multiverse Translation-en
Hit http://us.archive.ubuntu.com precise-updates/restricted Translation-en
Hit http://us.archive.ubuntu.com precise-updates/universe Translation-en
Hit http://us.archive.ubuntu.com precise-backports/main Translation-en
Hit http://us.archive.ubuntu.com precise-backports/multiverse Translation-en
Hit http://us.archive.ubuntu.com precise-backports/restricted Translation-en
Hit http://us.archive.ubuntu.com precise-backports/universe Translation-en
Ign http://packages.ros.org trusty/main Translation-en_US          
Ign http://packages.ros.org trusty/main Translation-en
Fetched 72 B in 4s (16 B/s)
Reading package lists... Done

Originally posted by rubicki on ROS Answers with karma: 3 on 2017-10-19

Post score: 0


Original comments

Comment by jayess on 2017-10-19:
Hydro reached end of life a while ago so I don't believe that the binaries are available for download anymore. I could be wrong but I seem to remember reading this somewhere (just can't recall where).

Comment by jayess on 2017-10-19:
Is there a reason that you need to use Hydro instead of a newer version such as Kinetic or Lunar?

Comment by gvdhoorn on 2017-10-20:
The package exists in the repositories, and you mention yourself that it works on "a typical Linux installation", so at this point it would seem you might've made a mistake when setting up the repositories.

Can you show the full output of sudo apt-get update? Use the edit button/link for that.

Comment by gvdhoorn on 2017-10-20:
@jayess: Hydro is EOL, but the package repository still has all the packages. They just won't receive any updates anymore.

Comment by jayess on 2017-10-20:
Ah ok. Must have been thinking of Fuerte or older. Thanks for the correction.

Comment by gvdhoorn on 2017-10-20:
All the packages for all older ROS releases - at least back to Box Turtle - are still available. If you can't install them, that either means the mirror you are using hasn't synced them, or your OS isn't compatible with them.

Comment by jayess on 2017-10-20:
Good point about compatibility. Forgot about that detail.

Comment by rubicki on 2017-10-20:
I have to use Hydro, because i am using ros to communicate with KUKA YouBot and a lot of packages were created for Hydro.

Comment by rubicki on 2017-10-20:
@gvdhoorn i will show you full output of sudo apt-get update

Comment by gvdhoorn on 2017-10-20:
re: have to use Hydro: as long as the message, service and action definitions (ie: .msg, .srv and .action files) haven't changed between Hydro and the ROS version you would like to use, things should just work.

And even if they've changed, you could recreate the msgs and use those to ..

Comment by gvdhoorn on 2017-10-20:
.. bridge into the YouBot Hydro node graph.

Note: I haven't done this, but it should be possible.

Comment by gvdhoorn on 2017-10-20:
Searching for kuka youbot indigo shows quite some results. Are you sure that there is no Indigo (at least) compatibility for what you need/want?

Comment by gvdhoorn on 2017-10-20:
Please edit your original question to add this new information. Comments are too limited for this.

Comment by rubicki on 2017-10-20:
Done, but i don't know how to format this like you correct

Comment by gvdhoorn on 2017-10-20:
Use the Preformatted Text button (the one with 101010 on it). Copy-paste your text, then select it, then press the button (or use ctrl+k).

Comment by rubicki on 2017-10-20:
@gvdhoom I am new here so i didn't know how do to it. Thank you!

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Skipping all the non-ROS related repositories, we see this:

Hit http://packages.ros.org trusty Release.gpg
Hit http://packages.ros.org trusty Release
Hit http://packages.ros.org trusty/main amd64 Packages
Hit http://packages.ros.org trusty/main i386 Packages
Ign http://packages.ros.org trusty/main TranslationIndex
Ign http://packages.ros.org trusty/main Translation-en_US
Ign http://packages.ros.org trusty/main Translation-en

The trusty there is what I would expect on a Ubuntu Trusty (ie: 14.04) system. For Ubuntu Precise (12.04), it should have precise in those lines.

All other output of apt-get update does show precise files being downloaded.

I have followed the ROS wiki instructions [..]

Did you follow the ROS Indigo installation tutorial by accident?

Can you tell us which instructions you followed specifically?


Originally posted by gvdhoorn with karma: 86574 on 2017-10-20

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by rubicki on 2017-10-20:
I followed this one: link text

Comment by gvdhoorn on 2017-10-20:
There is no trusty on that page anywhere.

You should be able to replace trusty with precise in /etc/apt/sources.list.d/ros-latest.list. Then do a apt-get update and try again to install ROS Hydro.

Comment by rubicki on 2017-10-20:
Ok. Should I remove ros which I installed before this step?

Comment by gvdhoorn on 2017-10-20:
Have you been able to install any packages? As far as I can tell, you shouldn't have been able to install any packages with the way you have things configured at this point.

Comment by rubicki on 2017-10-20:
Oh sorry my mistake. I just set up my keys.

Comment by rubicki on 2017-10-22:
@gvdhoorn everything is working. Thank you for helping me!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.