0
$\begingroup$

Rosanswers logo

Currently trying to install ROS Lunar on a clean Raspbian Stretch as per http://wiki.ros.org/lunar/Installation/Debian with this problem. I've done sudo apt-get update and returned with

Get:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease [15.0 kB]
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease                  
Get:3 http://packages.ros.org/ros/ubuntu stretch InRelease [4,008 B]           
Get:4 http://64.91.227.57/repos/rospbian wheezy InRelease [2,097 B]            
Get:5 http://mirrordirector.raspbian.org/raspbian stretch/main armhf Packages [11.7 MB]
Get:6 http://packages.ros.org/ros/ubuntu stretch/main armhf Packages [5,217 B]
Ign:4 http://64.91.227.57/repos/rospbian wheezy InRelease                      
Fetched 11.7 MB in 42s (275 kB/s)                                              
Error: Timeout was reached
Reading package lists... Done
W: GPG error: http://64.91.227.57/repos/rospbian wheezy InRelease: The following signatures were invalid: F57F2D123C1CB06171E8519AEDFBE3695B93BD6A
W: The repository 'http://64.91.227.57/repos/rospbian wheezy InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

followed by

$ sudo apt-get install ros-lunar-desktop-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-lunar-desktop-full

I also tried ros-lunar-desktop and got equivalent message.

What have I done wrong?


Originally posted by JGHunter on ROS Answers with karma: 61 on 2017-10-16

Post score: 1


Original comments

Comment by ahendrix on 2017-10-16:
Desktop-full depends on gazebo, which probably doesn't build for ARM. You may want to try installing the desktop or robot variants instead.

Comment by JGHunter on 2017-10-17:
Please see updated question (tried again this morning)

Comment by gvdhoorn on 2017-10-17:
The 'repository .. is not signed' points to problems. Did you import the repository key?

Comment by gvdhoorn on 2017-10-17:
Also: which package mirror are you using? Is it one of wiki/ROS/Installation/UbuntuMirrors? The files at http://64.91.227.57/repos look rather old and there are no files for Stretch, only Wheezy.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I had the same problem. It ended up being Raspbian Stretch is 32 bit architecture as indicated by stretch/main armhf. The repositories that have ros-lunar-desktop-full are in 64 bit which is not armhf. You are able to install the bare bones version of ROS onto Stretch which allows you to communicate to and from the Pi.

To be able to get 64 bit on the Pi I installed a new image from the following: https://github.com/bamarni/pi64/blob/master/README.md then I proceeded as normal to get it to install ros-lunar-desktop. I hope this helps.


Originally posted by Kong with karma: 16 on 2017-12-08

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by xtrix on 2018-07-11:
I get the same problem and I don't know how to fix it (probably will erase Stretch and install Jessie) I am new in this field and I don't understand much tech but also I don't understand why someone will build Lunar on 64bit but the OS needed is on 32bit.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.