0
$\begingroup$

Rosanswers logo

When trying to build nav2d_karto using catkin_make, I get the following error:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND. Please set them or make sure they are set and tested correctly in the CMake files: CSPARSE_INCLUDE_DIR used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto used as include directory in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto CSPARSE_LIBRARY linked by target "mapper" in directory /home/matt/catkin_ws/src/navigation_2d/nav2d_karto

-- Configuring incomplete, errors occurred! See also "/home/matt/catkin_ws/build/CMakeFiles/CMakeOutput.log". See also "/home/matt/catkin_ws/build/CMakeFiles/CMakeError.log". Makefile:9292: recipe for target 'cmake_check_build_system' failed make: *** [cmake_check_build_system] Error 1 Invoking "make cmake_check_build_system" failed

I can't seem to fix it. Does anyone know how to resolve this problem?

Thanks.


Originally posted by Matt31 on ROS Answers with karma: 1 on 2017-10-14

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Maybe you donot install csparse, try to install it.


Originally posted by l_a_den with karma: 26 on 2017-10-18

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Matt31 on 2017-10-20:
How do you install csparse? That seems to be just some script file.

Comment by l_a_den on 2017-10-22:
Try install libcsparse relative package.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.