0
$\begingroup$

Rosanswers logo

I have just installed ROS lunar on Ubuntu 17.04. I wanted to start with the urdf tutorial and tried to display the second model (02-multipleshapes.urdf) but rviz does not display the model. I do see the RobotModel Entry on the left side in the TreeView, the links are also there. But in the 3D view in the center I can only see an 3D axis with not mesh.

image description

edit:

rosparam get /robot_description 

outputs

"<?xml version=\"1.0\" ?>\n<!-- ===================================================================================\
  \ -->\n<!-- |    This document was autogenerated by xacro from /home/secret-path-to-my-workspace/urdf/01-myfirst.urdf\
  \ | -->\n<!-- |    EDITING THIS FILE BY HAND IS NOT RECOMMENDED                \
  \                 | -->\n<!-- ===================================================================================\
  \ -->\n<robot name=\"myfirst\">\n  <link name=\"base_link\">\n    <visual>\n   \
  \   <geometry>\n        <cylinder length=\"0.6\" radius=\"0.2\"/>\n      </geometry>\n\
  \    </visual>\n    <collision>\n      <geometry>\n        <cylinder length=\"0.6\"\
  \ radius=\"0.2\"/>\n      </geometry>\n    </collision>\n  </link>\n</robot>\n\n

which is actually the the same urdf file like in the tutorial (except for the collision part)


Originally posted by Westranger on ROS Answers with karma: 165 on 2017-10-10

Post score: 1


Original comments

Comment by gvdhoorn on 2017-10-10:
Without an image it's probably going to be hard to help you, so please attach one. I've just given you enough karma to do that.

Comment by Westranger on 2017-10-10:
@gvdhoorn thank you very much, I just added the image

Comment by gvdhoorn on 2017-10-10:
Can you make sure that robot_description contains the urdf that you think it does?

A rosparam get /robot_description should show that.

Comment by Westranger on 2017-10-10:
yes it does, I updated by post accordingly. I was switsching between the first and the second model form the turoial, both don't work for me. To me it looks like rviz does start but it cant visualize anything

Comment by gvdhoorn on 2017-11-20:
This could be caused by locale settings. See ros-visualization/rviz#1151.

Comment by Westranger on 2017-11-20:
@gvdhoorn my main system locale is in german and the VM where it worked was in english, I'll have a look into it

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Edit (2019-09-09): according to the latest comments on ros/urdfdom_headers#45 (specifically this one), the update to urdfdom_headers with the fix for non-US locales should be released for Ubuntu Bionic.

After installing the latest updates for Bionic overriding LC_NUMERIC should no longer be necessary.


original answer: highlighting @gvdhoorn's previous suggestion (for others that come across this issue) that the issue may be related to locales.

Some rviz users have encountered a similar issue on newer ubuntu/debian versions e.g. ROS Lunar on Ubuntu Artful or ROS Melodic on Ubuntu Bionic (see for example: https://github.com/ros-visualization/rviz/issues/1249).

If that's the underlying issue, modifying the following environment variable will fix it:

export LC_NUMERIC="en_US.UTF-8".


Originally posted by dhood with karma: 621 on 2018-07-09

This answer was ACCEPTED on the original site

Post score: 5

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.