0
$\begingroup$

Rosanswers logo

Hello I am trying to convert my point cloud data into map using octomap. I am newbie in this, so i would like to know what I am doing wrong. To create map these are steps I followed:

  1. rosbag info<mypoint_cloudbagfile> : OUTPUT: gives all the required information appropriately

  2. rosbag play <mypoint_cloudbagfile>

  3. Created my own Package

  4. Inside launch folder added this data: https://github.com/OctoMap/octomap_mapping/blob/master/octomap_server/launch/octomap_mapping.launch

  5. Updated Package.xml with required dependencies

  6. Updated CmakeLists.txt like this:

     cmake_minimum_required(VERSION 2.8.3)
     project(octomap_server)
    
    
    
     set(PACKAGE_DEPENDENCIES
       roscpp
       rospy
       std_msgs
       pcl_ros
       pcl_conversions
       visualization_msgs
       nav_msgs
       octomap_ros
       octomap_msgs
       #dynamic_reconfigure
       nodelet
       sensor_msgs
     )
    
    
     find_package(catkin REQUIRED COMPONENTS ${PACKAGE_DEPENDENCIES})
    
     find_package(PCL REQUIRED QUIET COMPONENTS common sample_consensus io segmentation filters)
    
     find_package(octomap REQUIRED)
    
     include_directories(
      include
      $(catkin_INCLUDE_DIRS)
         $(PCL_INCLUDE_DIRS)
      $(OCTOMAP_INCLUDE_DIRS)
        )
        catkin_package(
          INCLUDE_DIRS include
          LIBRARIES ${PROJECT_NAME}
       CATKIN_DEPENDS ${PACKAGE_DEPENDENCIES}
       DEPENDS octomap PCL
     )
    
     set(LINK_LIBS
         ${OCTOMAP_LIBRARIES}
            ${catkin_LIBRARIES}
         ${PCL_LIBRARIES}
     )
    
  7. ran launch file :

     roslaunch octomap_server octomap_mapping.launch
    

It runs but gives this error:

OUTPUT: ERROR: cannot launch node of type [octomap_server/octomap_server_node]: can't locate node [octomap_server_node] in package [octomap_server]

P.S.: I have already installed octomap_mapping using

sudo apt-get install ros-kinetic-octomap_mapping

Please tell me why this error occurs and how can I repair it to proceed in creating a map.

There are some solutions I tried:

  1. run rosrun octomap_server octomap_server_node to check node

I got this output:

Couldn't find executable named octomap_server_node below /home/ubuntu/catkin/src/octomap_server
  1. Source the bash file using:

    source ~/catkin_ws/devel/setup.bash

Thank You!


Originally posted by Eyshika on ROS Answers with karma: 1 on 2017-09-04

Post score: 0


Original comments

Comment by jayess on 2017-09-04:
Welcome. I edited your question to make it more readable. In the future, please format any terminal output/source code/etc. using the 101010 button to make it more readable.

Comment by Eyshika on 2017-09-05:
Thanx a lot.

Comment by jayess on 2017-09-08:
Are modifying the package.xml and CMakeLists.txt of the package that you downloaded? If so, why? Also, did you run catkin_make from the root for your workspace? I don't see that step listed.

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

This question pops up quite regularly and the solution is usually the same, source the setup.bash file:

source ~/catkin_ws/devel/setup.bash

Where catkin_ws is your catkin workspace. You can always Google the error to find a solution before posting a question:

https://www.google.com/search?q=OUTPUT%3A+ERROR%3A+cannot+launch+node+of+type+site%3Aanswers.ros.org


Originally posted by jayess with karma: 6155 on 2017-09-04

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by gvdhoorn on 2017-09-05:
Using Google to search ROS Answers is a good suggestion.

My suggestion: add site:answers.ros.org to the query. That will limit results to just this site.

Comment by jayess on 2017-09-05:
Good call. I updated the query to limit results to this site.

Comment by Eyshika on 2017-09-05:
@Jayess : I have already done that. My workspace bash file is already sourced. I googled the answer for this error and couldn't get the correct solution. that's why i thought of posting new question since it might be issue in Octomap_maping.

Comment by jayess on 2017-09-05:
@Eyshika: Without that information people are going to give to you the most common solution to that problem. Please update your question with what you have tried and what the results were.

Comment by Eyshika on 2017-09-07:
@jayess: I have updated my query. please check .

$\endgroup$
0
$\begingroup$

Rosanswers logo

I got the exact problem and here is what I did to resolve it on ros kinetic:

  1. Run (to install ros octomap packages): sudo apt-get install ros-kinetic-octomap ros-kinetic-octomap-mapping ros-kinetic-octomap-msgs ros-kinetic-octomap-ros ros-kinetic-octomap-rviz-plugins ros-kinetic-octomap-server

  2. Rebuild your workspace (i.e catkin_make)


Originally posted by meadows with karma: 31 on 2019-04-10

This answer was NOT ACCEPTED on the original site

Post score: 3


Original comments

Comment by askkvn on 2020-04-29:
I had same problem and your answer solved that, thank you

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.