4
$\begingroup$

To avoid wasting your time on this question, you might only want to react on this if you have knowledge of industrial robotic arms specific. Common troubleshooting is unlikely to fix this problem or could take too much time.

We've started a project with the Mitsubishi Melfa RV-2AJ robotic arm. Everything went fine until the moment we replaced the batteries.

The controller displays: "FAiL" and does not respond to any buttons or commands sent through serial connection.

We did replace the batteries of both the robot and the controller. As it took some time to get the batteries delivered, we've left the robot (and controller) withouth power for the weekend. (Which might have caused this problem)

Is there anyone with knowledge of Mitsubishi Robotic arms around here? I'm kinda hoping it would be a common problem/mistake and anyone with experience on this subject would know about it?

$\endgroup$
  • $\begingroup$ I'm not sure if this is the correct place for support/questions on industrial robotics. You should, in fact, contact the supplier if there are any problems (for security/legislable reasons). Though I found that this solution worked for me. And please don't delete this question, as it can be of much value to the community or other people having the same problem. Our supplier (not mitsubishi self) didn't know the problem and didn't react on it for around a week. $\endgroup$ – Paul Oct 15 '15 at 8:58
  • $\begingroup$ That's a common problem FuaZe. You are welcome to ask questions like this on robotics, but you are correct, Mitsubishi support are rather better placed to help. If this is a problem someone here has seen before though, you still might get an answer faster than from official sources. The only thing I ask is that if you do solve your problem, then please post your own answer here too. That way others might be saved waiting for the solution to the same problem in the future. Thanks, $\endgroup$ – Mark Booth Oct 16 '15 at 12:52
  • $\begingroup$ @MarkBooth Thanks for the clarification. And yes, we did contact "Festo", who would contact Mitsubishi about it. We didn't hear anything for a week (sent mail and called). So I hope this will help someone. But I have to wait a little before I can accept my own answer. $\endgroup$ – Paul Oct 16 '15 at 13:55
4
$\begingroup$

After some googling I found that there is an explanation & fix guide, only in German, for this.


It'll be of use for others having the same problem.

I'll try my very best to translate it a bit, please note that German, not English, is my main language:

Concerning "FAIL" in the display of the robotcontroller after voltage drop from back-up batteries (general). - KS00527

When the battery voltage is unsufficient to keep the buffer (which holds the settings of the powered-off robot), the display will show the message: "FAIL".

To reset this message/state, a RAM data reset is needed. After this reset, all programs and position data in the robotcontroller will be erased and the parameters will be reverted.

The procedure (RAM data reset) is as following:

  • Press STOP and RESET at the same time, while the controller is being activated.
  • The robot controller display would show "|----|".
  • Releave the STOP and RESET buttons.
  • Press RESET untill the display will show "EnG".
  • Press START once.
  • Press RESET until the display shows your Robot type
  • Press Start once.
  • The robot controller display would show "rAMc9".
  • After ~15-25 sec. (depending on the contents of the RAM?) you'll see a countdown from "100-0".
  • The message "ok" will appear on the dispaly.
  • Finally the robot will automatically reboot. (Didn't happen for us though)

I believe the procedure might differ a little per controller, but this would get you going.


The original text:

Anzeige FAIL im Display der Robotersteuerung nach Spannungsverlust der Pufferbatterien (General) - KS00527 Wenn die Batteriespannung die Einstellungen der ausgeschalteten Robotersteuerung nicht mehr puffern kann, zeigt das Display nach dem Einschalten die Anzeige FAIL an. Um diese zu beseitigen hilft nur ein RAM Daten Reset. Nach diesem Reset sind alle Programme, Positionsdaten in der Robotersteuerung gelöscht und die Parameter auf Werkseinstellung zurückgesetzt. Die Prozedur ist wie folgt : - Drücken Sie die STOP und RESET Taste gleichzeitig, während der Controller eingeschaltet wird. - Im Display wird ”I- - - -I” angezeigt. - STOP und RESET Taste loslassen - Die Taste RESET so oft drücken bis ”EnG” im Display angezeigt wird. - Drücken Sie einmal die START Taste. - Drücken Sie die Taste RESET oder STOP so oft bis im Display angezeigt wird. - Drücken Sie einmal die START Taste. - Im Display wird nun ”rAMc9” angezeigt. - Nach ca. 15-25 sec (abhängig vom Inhalt des RAM Speichers) sieht man im Display einen Countdown von ”100-0”. - Es erscheint kurz die Meldung ”ok” im Display. - Abschließend bootet der Controller selbsttätig neu.

Source: https://eu3a.mitsubishielectric.com/fa/en/service/knowledgebase?m_culture=de&ks=527

KS00527 of the GERMAN knowledgebase on Mitsubishi (Somehow German people may know things the English aren't allowed to? :D (You can't find it in English))

$\endgroup$
  • $\begingroup$ FuaZe, if this was the answer that solved your problem, you can accept your own answer. $\endgroup$ – Chuck Oct 15 '15 at 10:42
  • $\begingroup$ Thanks @FuaZe, it's obvious that you're familiar with how Stack Exchange works, so it's great to have to on board here at robotics. $\endgroup$ – Mark Booth Oct 16 '15 at 16:29
  • $\begingroup$ There seems to be a problem with the link. $\endgroup$ – Greenonline Oct 16 '15 at 16:54
  • $\begingroup$ @Greenonline I think the certificate of the mitsubishi website is invalid or something. For me it shows like this: imgur.com/EY35vbA (The red arrow indicates where the article can be found) $\endgroup$ – Paul Oct 16 '15 at 17:17
  • 1
    $\begingroup$ @Greenonline Ah, it seems to default to english, I'm going to try to get the German articale another way. $\endgroup$ – Paul Oct 19 '15 at 8:59
-1
$\begingroup$

All the steps are actually correct there- accept, when you press RESET, you curt need to select your Robot type, I usually just keep pressing RESET till I get USER, then press start & only then it displays ramclr or something

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.