0
$\begingroup$

Rosanswers logo

Straight dump of console output:

ImportError: No module named rosdep2.rospack
ImportError: No module named rosdep2.rospack
[rospack] Error: could not find python module 'rosdep2.rospack'. is rosdep up-to-date (at least 0.10.4)?
$ env | grep ROS
ROS_ROOT=/opt/ros/lunar/share/ros
ROS_PACKAGE_PATH=/home/perove/catkin_ws/src:/opt/ros/lunar/share
ROS_MASTER_URI=http://localhost:11311
ROSLISP_PACKAGE_DIRECTORIES=/home/perove/catkin_ws/devel/share/common-lisp
ROS_DISTRO=lunar
ROS_ETC_DIR=/opt/ros/lunar/etc/ros

Originally posted by PerOve on ROS Answers with karma: 1 on 2017-08-22

Post score: 0


Original comments

Comment by gvdhoorn on 2017-08-22:
This is not really a question. Please see our Support Guidelines.

Comment by PerOve on 2017-08-22:
What is the cause of this error.? I have subsequently re-installed a new kinetic instance in a virtual machine ubuntu 16.04 with python 3.6 (default). It appears to run now. I previously ran with 2.7 environment (Anaconda).. this now gives the same error. What Python should be used?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Lunar only supports Python 2.7 (see REP-3 and (fi) #q269143). If you want to use Anaconda, you'll have to make sure that all ROS Python packages have been installed for that as Anaconda does not use the default / system Python packages. That is most likely why you are getting that error.

There have been quite some questions and answers about Anaconda posted/resolved recently, so a search should provide some pointers.


Originally posted by gvdhoorn with karma: 86574 on 2017-08-22

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.