0
$\begingroup$

Rosanswers logo

Hi all,

this seems to be a widespread problem, but even with all the proposed solutions I don't seem to get it to work:

I am trying to use a Microsoft Kinect v2 with ROS.

The camera is connected and I can stream the images using

rosrun kinect2_viewer kinect2_viewer

Therefore I concluded that the basic connection to the camera is working fine. Unfortunately when I try to connect to the camera using freenect

roslaunch freenect_launch freenect.launch

I don't seem to be able to get it to work, producing the following error message:

[ INFO] [1503322404.266304684]: No devices connected.... waiting for devices to be connected

I have also tried using openNI, which produces the same error message in the process.

I know this is a well discussed error in the community and I've tried various suggested solutions from reinstalling freenect and openNI respectively, applying a patch (as seen in: https://answers.ros.org/question/60562/ubuntu-12042-and-openni_launch-not-detecting-kinect-after-update/) and everything else that was suggested...

But so far nothing seemed to work! Still getting the same error about not finding the Kinect...

Any sort of pointer or hint in a direction is extremely appreciated! I'm running out of ideas (even for new ways to google the issue!)

Thanks in advance everyone!

P.S.: I am using ROS Indigo and Ubuntu 14.04 with a Kinect v2 connected to a USB 3.0 port


Originally posted by budekatude on ROS Answers with karma: 21 on 2017-08-21

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

After trying lots of different drivers and setups I managed to get it to work after reinstalling everything and using Kinect2_bridge instead of openni or freenect (apparently they don't support the Kinect v2).

Simply following the installation instructions on GitHub will leave you with a working solution. (https://github.com/code-iai/iai_kinect2)

Thanks Solrac3589 for your suggestion!


Originally posted by budekatude with karma: 21 on 2017-09-08

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.