0
$\begingroup$

Rosanswers logo

I am trying to run rviz on kinetic. while running I get the following error.

$ rosrun rviz rviz
/opt/ros/kinetic/lib/rviz/rviz: symbol lookup error: /opt/ros/kinetic/lib/librviz.so: undefined symbol: _ZNK9QTreeView16viewportSizeHintEv

I tried dist-upgrade and remaking my catkin workspace but neither solved the problem. What might be the source of this issue?


Originally posted by Yaser on ROS Answers with karma: 1 on 2017-07-25

Post score: 0


Original comments

Comment by allenh1 on 2017-07-25:
It's really difficult to say without more information. What operating system/version are you running?

Comment by Yaser on 2017-07-27:
I'm using Ubuntu 16.04 LTS and ROS kinetic.

Comment by allenh1 on 2017-07-30:
What are you attempting to do with rviz?

Comment by Yaser on 2017-08-01:
I am trying to get Phantom Omni device work with ROS. I followed the instructions stated here: http://fsuarez6.github.io/projects/geomagic-touch-in-ros/ . However, when the launch node tries to start, the above-mentioned error appears.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I had the same problem, using Ubuntu 16.04 LTS and ROS kinetic, and I had also recently installed the Phantom Omni's geomagic touch device driver. It turns out that the geomagic touch device driver adds its own Qt5 dynamic library files in /opt/geomagic_touch_device_driver/lib and then adds that to the LD_LIBRARY_PATH. These are then used by rviz (among other Qt apps) instead of the correct ones. To find out if this applies to you as well, run:

echo $LD_LIBRARY_PATH

And if you see /opt/geomagic_touch_device_driver/lib included, that is the culprit. I personally didn't need any of the Qt functionality of the Phantom Omni, so I just stopped it from adding that directory to the LD_LIBRARY_PATH which can be done by editing the following file:

sudo nano /etc/profile.d/geomagic.sh

to remove the export LD_LIBRARY_PATH line, and possibly also the QT line. You will then have to reboot for these changes to take effect. This will possibly break your Phantom Omni if it needs the other non-Qt files in that directory. I just linked them to my /usr/lib directory, and now I can run the Omni code and rviz.


Originally posted by john.j.oneill with karma: 136 on 2017-10-17

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by JiaoYL on 2020-01-06:
how to use a Omni connect a real robot like ur5/Sawyer

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.