Rosanswers logo

Hello everyone, I'm new here and I'm trying to install turtlebot on a Raspberry Pi 2's Ubuntu OS. I've already installed ROS without errors and now I'm trying to install the Turtlebot following these instructions: http://wiki.ros.org/turtlebot/Tutorials/indigo/Turtlebot%20Installation I went directly to 1.2.2 Ubuntu Package Install and ran that code but I get the following error every single time:

Unable to locate package ros-indigo-turtlebot-simulator.

Searching on Google I found the next question: http://answers.ros.org/question/213483/unable-to-install-turtlebot/ Then the op says he/she found a workaround doing the following:

sudo apt-get install libsdformat1


sudo apt-get install ros-indigo-turtlebot ros-indigo-turtlebot-apps ros-indigo-turtlebot-interactions ros-indigo-turtlebot-simulator ros-indigo-kobuki-ftdi ros-indigo-rocon-remocon ros-indigo-rocon-qt-library ros-indigo-ar-track-alvar-msgs

Although it worked for him/her, it didn't work for me so I kept searching and found the next question:


The answer chosen as the correct one gives some directions even after following them I'm still unable to correct the error I showed you. One of the comments on that questions says:

Have you modified your /etc/apt/sources.list or any of the files in /etc/apt/sources.list.d/ since you installed ROS?

And I did modify because I had some problems when I was installing ROS and now that file looks like this:

deb http://ports.ubuntu.com/ubuntu-ports/ trusty main universe multiverse restr$
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty main universe multiverse r$
deb http://ports.ubuntu.com/ubuntu-ports/ trusty-updates main universe multiver$
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty-updates main universe mult$
deb http://ports.ubuntu.com/ubuntu-ports/ trusty-security main universe multive$
deb-src http://ports.ubuntu.com/ubuntu-ports/ trusty-security main universe mul$

Maybe this is the problem, does anybody know how to correct this? I really want to start working with the turtlebot.

Thanks in advance!

Originally posted by Nexo on ROS Answers with karma: 3 on 2017-07-17

Post score: 0


1 Answer 1


Rosanswers logo

The turtlebot simulator depends on gazebo, and gazebo isn't available for Ubuntu running on the Raspberry Pi 2.

Assuming that you're followed the installation instructions on http://wiki.ros.org/indigo/Installation/UbuntuARM , if you follow the link to the package status page and search for turtlebot_simulator ( http://repositories.ros.org/status_page/ros_indigo_arm.html?q=turtlebot_simulator ), you can see that the Thf column for turtlebot_simulator is red, indicating that the binary package isn't available for Trusty.

This usually happens because there are missing dependencies or compilation errors when trying to build packages on ARM, and they don't usually get fixed because there is low demand for these packages, and many of the complex simulation packages like Gazebo run too slowly on ARM to be useful anyway.

I suggest that you install the turtlebot_simulator package on an x86 desktop, laptop, or virtual machine instead.

Originally posted by ahendrix with karma: 47576 on 2017-07-17

This answer was ACCEPTED on the original site

Post score: 2

Original comments

Comment by Nexo on 2017-07-17:
Thank you very much for your answer! I would really like to install it on a desktop computer or a laptop but we need to install it in the RPi2 because we are making a small car-robot base on this embedded system. Is there a workaround? Maybe to install it on a RPi3 using Ubuntu?

Comment by Nexo on 2017-07-17:
We tried installing ROS using Raspbian but we got too many errors and it was impossible to find a workaround. Any suggestion will be really appreciated.

Comment by gvdhoorn on 2017-07-18:
To be able to run the base turtlebot packages you don't need to install the simulator on your RPi. In fact, I would rather not do that, as the Pi is really not powerful enough to comfortably run something like Gazebo.

Comment by Nexo on 2017-07-26:
Thank you very much, I've installed Ubuntu on my laptop which will dual-boot along with my Windows OS and then installed ROS without problems. Thanks you for your help and I apologize for taking too long to answer back.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.