0
$\begingroup$

Rosanswers logo

Hello everyone,

I am currently trying to connect my arduino due to my pc in order to run my ROS package I wrote, which shall communicate with the arduino.

I can compile and upload my program via the GUI. To start the serial connection, I run:

rosrun rosserial_python serial_node.py /dev/ttyACM0

Which produces the output:

[INFO] [1499369503.299387]: ROS Serial Python Node
[INFO] [1499369503.305172]: Connecting to /dev/ttyACM0 at 57600 baud
[ERROR] [1499369520.430946]: Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

I don't really understand the message. I wrote all my nodes in ROS kinetic and also installed rosserial via:

sudo apt-get install ros-kinetic-rosserial-arduino
sudo apt-get install ros-kinetic-rosserial

just like it was done in the tutorial.

Why is the arduino assigned to a particular ROS version anyway? How can I set this to kinetic?

I am working on a virtual box with Ubuntu 16.04

Does somebody know how to solve that problem?

Thanks in advance,

Felix


Originally posted by Felix_N on ROS Answers with karma: 115 on 2017-07-06

Post score: 0


Original comments

Comment by gvdhoorn on 2017-07-06:\

such as hydro rosserial_python with groovy Arduino

this is an example. It does not refer to exact versions of anything. It's basically giving you one specific example of a cause for this issue (ie: using different versions of things).

Comment by Felix_N on 2017-07-06:
I know. But still i have no idea how to solve this.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

It now works on an Arduino Mega 2650. Same settings, same code, works.

It even got the same amount of pins available.


Originally posted by Felix_N with karma: 115 on 2017-07-09

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.