0
$\begingroup$

Rosanswers logo

I'm trying to use STOMP in moveit as the path-planner, instead of using the default planner. I've followed all the steps here: https://github.com/ros-industrial/industrial_training/wiki/Introduction-to-STOMP. First I created a “stomp_planning_pipeline.launch.xml” file, then the "stomp_planning.yaml" configuration file, and modified the "parameter" value in ”move_group.launch“. I've made sure the file paths are correct. I also had the following lines of code in my cpp file to set the planner to STOMP:

moveit::planning_interface::MoveGroup group("arm");
group.setPlannerId("STOMP");

Since I wasn't sure how to install the STOMP plugin, I just ran the command "sudo apt-get install ros-indigo-stomp-moveit", which, along with the stomp-moveit plugin, also installed the stomp-core plugin. I also installed the industrial_moveit plugin. However, when I ran the launch file, I'm getting the following error:

[ERROR] [1499143566.205198927]: The 'stomp' configuration parameter was not found terminate called after throwing an instance of 'std::runtime_error'
what(): Unable to initialize planning plugin

I'm using Indigo. My stomp_planning.yaml file is almost ideal to this one except the group name: https://github.com/ekuri/baxter_moveit_stomp_trac_ik_config/blob/master/config/stomp_planning.yaml

Any help is appreciated. Thanks!


Originally posted by fittaoee on ROS Answers with karma: 1 on 2017-07-03

Post score: 0

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

Hello,

I reviewed your moveit config and it looks like your config file is not setup correctly. Please take a look at the one below. All parameters for a group should be name spaced "stomp/group_name:" so in your case it should "stomp/arm:", followed by the parameter "group_name: arm". Also could you provide a link to the config file you used to create yours from? It contains additional parameters that I cannot find being used in the source code.

STOMP Config


Originally posted by Levi-Armstrong with karma: 106 on 2017-07-05

This answer was NOT ACCEPTED on the original site

Post score: 2


Original comments

Comment by fittaoee on 2017-07-05:
Thank you! I copied the config file you provided and changed the group_name, and that error was gone. However, now I see another error, which says: [ERROR] [1499307738.017898024]: STOMP: Can only handle joint space goals. What might be the cause of this? Thanks again.

Comment by fittaoee on 2017-07-05:
I saw your answer in a google group that one should "use the RobotState::setFromIK to get a set of joints for the given pose and pass that to STOMP to solve the issue". But I wonder how exactly should I pass something of type "robot_state::RobotState" to STOMP? Any example code that I follow? Thanks

Comment by Levi-Armstrong on 2017-07-06:
Take a look here. You want to set a joint goal.

$\endgroup$
0
$\begingroup$

Rosanswers logo

Hello The configuration file you pointed to corresponds to an old version of stomp. The link provided in the first answer points to the new configuration file format. For more details on the configuration file go to the link below.

stomp_moveit


Originally posted by jrgnicho with karma: 486 on 2017-07-05

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by fittaoee on 2017-07-05:
Thank you.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.